Showing results for 
Show  only  | Search instead for 
Did you mean: 

Inventories showing multiple flexera agent


I did a test to upgrade the flexnet inventory agent using the agent automatic deployment but post the upgrade I can still see the old agent in the inventory.
When I checked on the device, only one agent is showing installed. I can see this issue on all OS. 
I tried uninstalling the old version and installing a new one manually but still inventory from that device is showing two agents.


Any suggestions


(2) Solutions

I think deleting old SCCM connection might help in your case .

View solution in original post

Deleting the old inventory source Under the Data Inputs > Inventory Data did resolved my issue.
Now I can see only one agent in those inventories.
Thanks @durgeshsingh @ChrisG @kclausen @ajinkyaestee 

View solution in original post

(12) Replies

Hi Sushant,

Please run below & check in NDi file if you are getting two version. Upload that NDI in application server & perform recon to check it again. -t machine  -o Upload=false -o LogFile=/var/tmp/inventory.log


@sushant_narula - Go to the EVIDENCE tab of this inventory device.  Filter on the application name to see what raw evidence is being found to identify the 2019 R2 install of the agent.  My guess is that it is finding a Software ID Tag, which means that the upgrade process is not deleting the SWID tag for the old version.

Can you verify that this is happening?


Please find evidence tab snap. I can also see the same behavior for our env.

OK, this is a similar issue, but on Windows.  Looks like the Upgrade process does not delete the MSI file from the older install, which the new agent picks up.

Strange think , there is no entry for old version in NDI. If its present in server then NDI must have this info.

i have filtered with flexera keyword & extract below output of NDI.


Line 2061: <Key Name="DisplayName" Value="FlexNet Inventory Agent"/>
Line 2389: <Package Name="FlexNet Inventory Agent" Version="18.00.452" InstallDate="20220510T000000" Evidence="MSI">
Line 2391: <Property Name="InstalledProductName" Value="FlexNet Inventory Agent"/>
Line 3299: <Package Name="FlexNet Inventory Agent" Version="18,00,452,0" Evidence="ManageSoft" InstallDate="20220510T130039">

@durgeshsingh - In your NDI file, look at lines 2055 - 2075.  That is likely the MSI evidence for the old install (line 2061 has a package name of FlexNet Inventory Agent)

@durgeshsingh @kclausen 

Below is the evidence tab screenshot (its a windows device). FNMS reconciled once since I enabled the auto upgrade, Shall I run another reconcile ?


@sushant_narula - In your case, you will need to wait until the SCCM Agent has run a new scan on the device.  If you look at the evidence for the older version of the agent, it is from SCCM, with an older inventory date.  Once the SCCM Agent runs a new scan, it will pick up the new version of the agent that is installed and will not see the old version.  After that is imported into FNMS and a reconcile has run, then you will no longer see the old version being installed.

The other thing that jumps out at me here is that it looks like there may be 2 computer records in the SCCM database that are getting mapped to this one inventory device: one old with a Feb 2022 inventory date and one with a current inventory date.

I can't tell from this screenshot why that would be, but the old agent version will remain recognized until/unless the evidence of that version is removed from SCCM.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

@ChrisG @kclausen Three months back I upgraded the FNMS and somehow the SCCM connection in beacon got deleted. I recreated them with the same name (enabled ones) which was there in beacon before the upgrade.
Last week while working on the issue I checked the data inputs, I found that the old ones are still enabled (yellow highlighted) and last updated in march. I have disabled them last week, but after couple of reconcile since then, I can still see the inventory has 2 flexera agents.
Any suggestions. Also I am working on SCCM scans.


I think deleting old SCCM connection might help in your case .

Deleting the old inventory source Under the Data Inputs > Inventory Data did resolved my issue.
Now I can see only one agent in those inventories.
Thanks @durgeshsingh @ChrisG @kclausen @ajinkyaestee