Highlighted
Occasional contributor

Database Migration

Jump to solution

Hi,

I have been reading that page, which indicates that FNMS is compatible with Windows Server 2017.

Currently our FNMS database runs the 2016 SP1 version - but we would like to make an update for security reasons. Can we safely migrate our DB to Windows Server 2017 without risks ?

Have a nice day.

 

Paul

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
Community Manager Community Manager
Community Manager

Re: Database Migration

Jump to solution
I'm not sure if you have a typo here somewhere, but there is no "2017" version of Windows Server. After Windows Server 2016, the next version was 2019.

With that said, FlexNet doesn't actually care too much about the operating system version that the database server runs. As long as the version of SQL Server you are using supports the operating system you are running it on, you should be fine.
(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)

View solution in original post

Highlighted
Community Manager Community Manager
Community Manager

Re: Database Migration

Jump to solution
Ahh, OK - that's a slightly different question to what I answered previously.

SQL Server 2017 is not formally supported by FlexNet Manager Suite 2016 R1 (as the SQL Server version wasn't even released at the time that version of FlexNet Manager Suite was release). Pragmatically it is likely that it will work OK, but you will be going into somewhat untested and unsupported territory if you try it.
(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)

View solution in original post

4 Replies
Highlighted
Community Manager Community Manager
Community Manager

Re: Database Migration

Jump to solution
I'm not sure if you have a typo here somewhere, but there is no "2017" version of Windows Server. After Windows Server 2016, the next version was 2019.

With that said, FlexNet doesn't actually care too much about the operating system version that the database server runs. As long as the version of SQL Server you are using supports the operating system you are running it on, you should be fine.
(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)

View solution in original post

Highlighted
Occasional contributor

Re: Database Migration

Jump to solution
My bad, I actually meant "Windows SQL Server 2017".
Thank you for your answer.
0 Kudos
Highlighted
Community Manager Community Manager
Community Manager

Re: Database Migration

Jump to solution
Ahh, OK - that's a slightly different question to what I answered previously.

SQL Server 2017 is not formally supported by FlexNet Manager Suite 2016 R1 (as the SQL Server version wasn't even released at the time that version of FlexNet Manager Suite was release). Pragmatically it is likely that it will work OK, but you will be going into somewhat untested and unsupported territory if you try it.
(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)

View solution in original post

Highlighted
Occasional contributor

Re: Database Migration

Jump to solution

Well thank you for this information.

0 Kudos