cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mfranz
Level 16 Champion
Level 16 Champion

All Inventory - Inventory Chassis Type empty

Jump to solution

Hi,

A customer asked me about the "Inventory chassis type" field. In the "All inventory" view, values are missing or "Unknown", while in the inventory itfelf the value is set. I double checked it in my test environment and see the same bahaviour.

2019-08-20_12h54_58.png

Can anyone confirm this?

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
1 Solution
kclausen
Level 15 Flexeran
Level 15 Flexeran

I can replicate this in 2019 R1 On-Premises, but not in 2019 R1 Cloud.  Looks like it has been identified as a defect and the fix has already been applied to the Cloud. 

Therefore, I expect that this issue would be fixed in 2019 R2 On-Premises.

Kirk

View solution in original post

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

6 Replies
ChrisG
Community Manager Community Manager
Community Manager

I'm not sure that it helps a whole lot, but I am unable to reproduce behavior like is described here in FlexNet Cloud. I see "Inventory Chassis Type" values in the "All Inventory" grid as expected:

image.png

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

Hi Markward,

I see that issue occurring in my own local install of FNMS 2019R1.  It looks like a defect to me as the list view of computers sources data from Grid_ComputerListModel* and the individual properties page of a computer sources data from the ComplianceComputer* - however the ChassisType retrieved is not the same from both, the NULL in the first query results in the empty chassis type column in the grid view.

chassis.PNG

-Murray

Hi Markward,

 

I can confirm that I see the same issue on my implementation.

FNMS 2018 R2 and FNMS 2019 R1 on prem implementation.

Hi @MurrayPeters@adrian_ritz1,

Thanks for your confirmation. I had the assumption that a view or something like that must be defect. Unfortunately none of the "Grid_" objects are mentioned in the schema reference.

2019-08-21_11h41_17.png

There are some stored procedures referring to this table, but they seem to call CLR precedores and the assembly is binary, so I cannot see inside of them. Intelectual property and stuff... 😄

I'll have to open a case.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos
kclausen
Level 15 Flexeran
Level 15 Flexeran

I can replicate this in 2019 R1 On-Premises, but not in 2019 R1 Cloud.  Looks like it has been identified as a defect and the fix has already been applied to the Cloud. 

Therefore, I expect that this issue would be fixed in 2019 R2 On-Premises.

Kirk

Just to confirm what you said, support gave me the info: "[...] The fix FNML-4189 is , as I say , scheduled for a Q4 release, but in the meantime there is a workaround which is as follows: Using report builder, build a report for inventory device, select chassis type in addition to other required properties [...]"

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos