cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Agent compatibility with Beacon versions

Jump to solution

Does documentation exist that I can use as proof of backwards compatibility of the newest version of the Beacon application with older versions of the FlexNet Agent? Specifically I have a customer on 2017R3 that needs to upgrade their Beacon to be compatible with the new way of doing Office 365 inventory and they are concerned that their older agents will not be able to report into the newer Beacon (and they do not want to upgrade agents at this time).

0 Kudos
1 Solution
ChrisG
Community Manager Community Manager
Community Manager

In the release notes for the FlexNet version you are using, look in the section Compatibility with other products > Inventory components for details of compatibility across versions. Generally older agents will be forward compatible with newer FlexNet servers (upgrade nightmares would result if this wasn't the case!).

It is also true that newly released agents will normally work with older FlexNet servers, although release notes do not explicitly state this compatibility as what will happen in the future isn't known with absolute certainty at the time release notes for a release are published.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

1 Reply
ChrisG
Community Manager Community Manager
Community Manager

In the release notes for the FlexNet version you are using, look in the section Compatibility with other products > Inventory components for details of compatibility across versions. Generally older agents will be forward compatible with newer FlexNet servers (upgrade nightmares would result if this wasn't the case!).

It is also true that newly released agents will normally work with older FlexNet servers, although release notes do not explicitly state this compatibility as what will happen in the future isn't known with absolute certainty at the time release notes for a release are published.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)