rflores
Level 3

Agent Deployment - HTTP error 500 Internal Server Error

Jump to solution

On multi-tenant implementation, we are currently deploying agents to a Windows workstation.

We encountered the following issues and I am wondering if anyone has a resolution/answer to any of these.

1. The DEPLOYSERVERURL is specified in mgssetup.ini, however the Base URL is not being populated. We "resolved" this by adding a line in the .ini file to specify the DownloadRootURL. Is this the right approach?

2. After adding the DownloadRootURL line, the Base URL is now populated. However the agent is unable to download policies and installation.log is showing HTTP Error 500: Internal Server Error. Has anyone encountered this issue before?

 

Thanks,

Rizhelle

0 Kudos
1 Solution

Update:

The issue was resolved by deleting the line which causes the issue from the Web.config file.

Flexera support advised that there might be another configuration file at a higher level, adding the same entry of "Flexera-ReportLocation-PUT-MKCOL-Protocol" and it caused the duplicate entry.

View solution in original post

7 Replies
adrian_ritz1
Level 9

Hi Rizhelle

Probably the issue is with your beacon server.

How is your beacon server configured, to use IIS or to use self hosted beacon server.

Also please check and confirm the following:

IIS Roles/Services
Below are the Microsoft Internet Information Services (IIS) roles and services utilized by FlexNet Manager Suite. In
the event of misbehavior, it is often helpful to validate that all of the following are enabled on all your central
servers (depending on the scale of your implementation, the ones that you have implemented from the
application server, the web application server, the processing server, the batch server, and the inventory server).
The process for checking whether the services are enabled is summarized below the list.
• Web Server > Application Development > .NET Extensibility
• Web Server > Application Development > ASP.NET
• Web Server > Application Development > CGI
• Web Server > Application Development > ISAPI Extensions
• Web Server > Application Development > ISAPI Filters
• Web Server > Common HTTP Features > Default Document
• Web Server > Common HTTP Features > Directory Browsing
• Web Server > Common HTTP Features > HTTP Errors
• Web Server > Common HTTP Features > HTTP Redirection
• Web Server > Common HTTP Features > Static Content
• Web Server > Health and Diagnostics > HTTP Logging
• Web Server > Performance > Dynamic Content Compression
• Web Server > Performance > Static Content Compression
• Web Server > Security > Basic Authentication
• Web Server > Security > Request Filtering
• Web Server > Security > Windows Authentication

Install ASP.NET (which also registers ASP.NET with IIS when present), for example with the platformappropriate
commands:
For operating systems up to Windows Server 2008 R2, use:
aspnet_regiis.exe -ir -enable
For Windows Server 2012, use:
dism /online /enable-feature /featurename:IIS-ApplicationDevelopment
dism /online /enable-feature /featurename:IIS-ISAPIFilter
dism /online /enable-feature /featurename:IIS-ISAPIExtensions
dism /online /enable-feature /featurename:IIS-NetFxExtensibility45
dism /online /enable-feature /featurename:IIS-ASPNET45

Also please check the IIS log from the beacon server, you should see why you receive this error. I received in past such an error and was because I forgot to configure the ASP.NET

Also posting the log file would be helpful

Regards,

Adrian Ritz

Thanks Adrian,

I did make sure that the IIS Roles/Services are enabled, however when browsing to https:\\localhost\managesoftdl we are still getting the Internal Server Error.

I have attached the error page we're getting and it is suggesting that there is something wrong with the Web.config file.

 

0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

This does indeed look to be related to something wrong in the web.config file. Can you share a copy of the file here? Or at least share the contents of the <handlers> section of the file?

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

See below for the contents of the Web.config file

This seems strange to me because we never changed anything on this file (It should be the file created as part of installation). And the contents are the same as that in the properly working Master beacon (the issue is being encountered in a child beacon).

 

<?xml version="1.0" encoding="UTF-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
 <configSections>
  <section name="hostIndependentSection" type="Flexera.Beacon.Common.WebServerConfig.ConfigSections.HostIndependentSection, Flexera.Beacon.Common" allowExeDefinition="MachineToApplication" />
 </configSections>
 <system.web>
  <customErrors mode="Off" />
  <httpRuntime maxRequestLength="30000000" requestLengthDiskThreshold="30000000" />
  <hostingEnvironment shadowCopyBinAssemblies="false" />
  <compilation debug="false" targetFramework="4.0">
   <assemblies>
    <remove assembly="*" />
    <add assembly="Flexera.Beacon.IISWeb" />
    <add assembly="Flexera.Beacon.Web.Shared" />
    <add assembly="Flexera.Beacon.HostIndependentWebService" />
    <add assembly="Flexera.Beacon.Data" />
    <add assembly="Flexera.Beacon.Common" />
    <add assembly="Flexera.SaaS.Rules" />
    <add assembly="Flexera.SaaS.Transport" />
   </assemblies>
  </compilation>
  <authentication mode="None" />
  <identity impersonate="false" />
  
 </system.web>
 <system.webServer>
  <modules runAllManagedModulesForAllRequests="true">
   <remove name="WebDAVModule" />
  </modules>
  <handlers>
   <remove name="WebDAV" />
   <add name="Flexera-ReportLocation-PUT-MKCOL-Protocol" path="*" verb="PUT,MKCOL" modules="ProtocolSupportModule" resourceType="Unspecified" requireAccess="None" />
  </handlers>
        <security>
            <authentication>
                <anonymousAuthentication enabled="true" />
                <basicAuthentication enabled="false" />
            </authentication>
        </security>
 </system.webServer>
 <hostIndependentSection>
  <commonConfig commonConfigFile="..\conf\BeaconEngine.config" />
 </hostIndependentSection>
 <runtime>
  <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
   <dependentAssembly>
    <assemblyIdentity name="Autofac" publicKeyToken="17863af14b0044da" culture="neutral" />
    <bindingRedirect oldVersion="0.0.0.0-3.5.0.0" newVersion="3.5.0.0" />
   </dependentAssembly>
  </assemblyBinding>
 </runtime>
</configuration>

0 Kudos

Update:

The issue was resolved by deleting the line which causes the issue from the Web.config file.

Flexera support advised that there might be another configuration file at a higher level, adding the same entry of "Flexera-ReportLocation-PUT-MKCOL-Protocol" and it caused the duplicate entry.

mfranz
Level 15

Hi,

In the past I found HTTP 50x errors repeatedly being connected to local rights issues, like the webserver accessing the local folder structure. You might want to check in which context you Beacon service, IIS and Application Pools run (Local System, a service account, etc.) and see how the folder rights (C:\ProgramData\Flexera Software\) are set in regards to them.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.

Thanks mfranz,

Beacon service is running with a service account, IIS and Application Pools have Anonymous Authentication enabled. Can you guide me on what/how else (if any) needs to be checked in regards to folder rights?

 

Cheers,

Rizhelle

0 Kudos