Not supported special characters for Flexera Data Platfrom and User Console and Database Server

Not supported special characters for Flexera Data Platfrom and User Console and Database Server

Symptoms:

1. Data Platform service and User Console service is not able to start after changing the password of service account.
2. Re-run Data Platform config wizard will fail at "Start Data Platform service.." step with error - "Cannot load TAPI.."
3. Use Console service cannot start up.
4. Re-run User Console Config wizard will fail -
a. Connect to Data Platform server
b. Start User Console service timeout
5. Even you can manually start the Data platform service, but you will not be able to open the Admin UI and not able to visit the below URL -
 
 
Solution:
Please remove the below special characters from the password of the service/management account and DB account.
 
Not Supported Special Characters:
1. For LDAP account:
: " ' =
 
2. For WA account:
= : < > \
 
3. For Database account:
= ; '
Labels (2)
Was this article helpful? Yes No
No ratings
Comments

Updated -

Character '£' is not supported

Hi, our team was the one who specifically requested the enhancement to fix this issue, and the changes went in with .30 as far as i know and as you can see in the release notes (as of 5/31/2020)

Can we get a confirmation that this applied to ALL special characters and if not which are the current exception characters, because i'm just about to request security to update the password policy for our service accounts for Data Platform to go back to using special charters.

Data Platform 5.5.30 Release Notes

32518 Support for special characters for Admin Console login.

Version history
Revision #:
1 of 1
Last update:
‎Jun 16, 2020 10:33 AM
Updated by:
 
Contributors