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"HTTP Error 503 Service un-available" when accessing App Portal.
"HTTP Error 503 Service un-available" when accessing App Portal.
Summary
"HTTP Error 503 Service un-available" when accessing App Portal.Symptoms
When accessing App Portal the following error message is displayed in the browser;
"HTTP Error 503 Service un-available", this message is present in multiple browsers for different users.
A screenshot of the error is below:
Cause
This error appears when the web application is unavailable, this means that the site is up and running but the underlying application pools have an issue. The first place to check is the Application Pools node in IIS, the Application Pool is called "SelfService".
If this Application Pool is stopped, this will cause the error message when accessing the Web UI for App Portal.
Resolution
In order to resolve this you should start the application pool and if it fails to start you need to look at Windows event logs to see what errors are shown.
This is most common when a specific account is used as the application pool identity (This is a common configuration) as you can see in the screenshot below. In most cases when this error occurs it is because the username / password is incorrect and so the event log will show failed logon attempts.
In this case, simply update the password for the Identity account in the Application Pool advanced settings and restart the application pool.
The following steps can be used to verify this:
-Open IIS.
-Select the "SelfService" Application Pool.
-Stop the Application Pool.
-Select "Advanced Settings" in the right hand panel.
-Expand "Process Model" and the select the (...) for the Identity.
-Ensure the credentials including the domain and the PW are re-entered by using the "Set" button and select ok.
-Start the Application Pool and test the issue.
IIS View:
Additional Information
While the identity account is the most common cause of the application pool being stopped, it is not the only cause. If updating the password doesn't work, try and restart the application pool and investigate Windows event logs to find specific details on why it failed to start.