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Unable to Successfully Register Intune with App Broker
Unable to Successfully Register Intune with App Broker
Symptoms:
After entering the Intune settings in App Broker, the error is displayed upon selecting the Test button: "Failed to communicate with Intune. Please verify the configuration settings and make sure minimum permission is provided.
In addition to the above error message, the intune.log file will contain an exception that states:
Failed to communicate with Intune, either the configuration settings are invalid or minimum permission is missing (Application.Read.All): Response status code does not indicate success: 404 (Not Found).
Diagnosis:
While this error may occur for multiple reasons, the most common reason is entering the incorrect value for the Principal ID setting in App Broker.
Solution:
When entering the Intune configuration settings, The Tenant ID/Tenant Name and Client ID can be captured directly from the Application overview page in Azure. In the following screen capture, the properties on the App registration are displayed.
The Application (client) ID and Directory (tenant) ID shown in yellow should be entered into the Intune settings directly. The Object ID that is highlighted in red is not the correct Principal (Object ID) to use. To retrieve the correct Principal ID, you must select the link under "Managed application in local directory". This is shown in green. Once the link is selected, the correct Principal ID (Object ID) is displayed, as shown below:
For additional information on Configuring Intune in App Broker, see Entering Intune Settings at Initial Start Up in the Administration Guide