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Summary

While attempting to integrate ServiceNow and App Broker an error occurs related to permissions in ServiceNow.

Symptoms

While attempting to perform any of the integration steps between App Broker and ServiceNow an error occurs. With verbose logging enabled the ServiceNowIntegration.log shows:
Error while performing ITSM operations Exception has been thrown by the target of an invocation. com.glide.processors.soap.SOAPProcessingException: Insufficient rights for creating new records at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at AppPortal.Business.WebServiceInvoker.InvokeMethodAndReturnObject(String method, Object[] parameters, Int32 requestid)


Cause

This issue is most commonly seen in the following scenarios:
  1. The ServiceNow User Account defined in the ServiceNow Integration Page of App Broker does not have the required roles.
  2. The ServiceNow User Account defined in the ServiceNow Integration Page of App Broker has been changed to a new user that has the required roles.

Resolution

Please see the related KBs and documentation below for a resolution to each scenario above.
  1. Configuring a ServiceNow User Account for Integration with App Broker
  2. Changing the ServiceNow Integration User Account Credentials

Additional Information

Using App Broker for ServiceNow
Creating a ServiceNow Integration User
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Version history
Last update:
‎Jan 16, 2019 09:27 PM
Updated by: