Windows Installer Error 1619
Summary
Discussion on possible causes and resolutions for run time error 1619Symptoms
While running a setup created with Express, following error occurs:Error 1619: Database could not be opened.
Cause
This error is a generic Windows Installer error message. The error is system specific and can be caused due to some conflict on the system.
Some common causes are:M
- The temp directory on the system is full.
- Setup fails to extract files properly on the machine.
- Windows Installer Service is not properly configured on the machine.
Resolution
Delete all file in the default System Temp directory by following these step:
- Launch the file cmd.exe on Windows NT, Windows 2000, or Windows XP machines or DOS prompt on Windows 9.X or Windows Me machines.
- Type Set on the command prompt and press Enter. This displays all the environment variables on the machine including TEMP.
- Navigate to the path listed in TEMP and delete all the files in this directory.
- Relaunch the installation to see if it works.
Instead of Launching Setup.exe, try running the .msi file itself. This file should be in the same location as Setup.exe. It bears the same name as the product (for example, myproduct.msi).
- If Setup.exe is compressed, then uncompress Setup.exe via the following command line argument to obtain the .msi file:
<PATH>\Setup.exe /v /a
This displays a dialog that allows you to extract setup files to a specified location.
- After extracting files to the desired location, run the MSI package.
This error can also occur if the Windows Installer service is corrupt or not properly configured on the machine. To reinstall the Windows Installer Service, run the file InstmsiA.exe on Windows 9X or Windows Me or InstmsiW.exe on Windows NT, Windows 2000, or Windows XP machines.
- These files can be found in the same location as Setup.exe in an uncompressed release.
- These files can also be found in the following location on the development machine where InstallShield Express is installed: \Program Files\InstallShield\Express\Redist\Language Independent\i386.
Note: The above path presumes InstallShield Express is installed to its default location.
Additional Information
To download the latest version of the Windows Installer service, see MSDN Article Q292539 How to Obtain the Windows Installer Engine.