Summary
Information about runtime error.
Symptoms
When running an installation, a 1603 error message occurs similar to one of the following:
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Error 1603: Fatal Error During Installation
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Error 1603: General Windows Installer engine error. Increase DiskSpace requirement in Setup.ini and try again
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Error 1603: A fatal error occurred during installation
Cause
Error 1603 is a generic system specific error generated by the Microsoft Windows Installer (MSI). Listed below are some common causes and their resolutions.
Resolution
A. Short File Name Creation is Disabled on the Target Machine
Enable support for 8.3 name creation, i.e. short file names, on the target machine. Navigate to the following registry entry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystemA NtfsDisable8dot3NameCreation value of 0, zero, enables the short file name creation functionality and a value of 1 disables this functionality.
Registry modifications require rebooting the target machine for the change to take affect and this should be done before attempting to launch the setup again.
Note: If the target machine should normally have short file name creation disabled, it can be disabled after the install completes by resetting NtfsDisable8dot3NameCreation to 1 and rebooting.
B. An InstallScript Custom Action is Prototyped Incorrectly
Verify the correct prototype syntax for
entry-point function declarations of InstallScript custom actions, if any have been included in the setup. An example of a correct prototype is:
export prototype MyFunction(HWND);
Note: HWND must be specifically referenced in the prototype. All InstallScript functions called via custom actions must accept a HWND parameter. This parameter is a handle to the Microsoft Windows Installer (MSI) database.
C. A File is Locked and Cannot be Overwritten
A certain file on the machine is locked, or setup attempts to reboot because of a locked file, which fails.
To make sure that a locked file is not causing the error, close all applications running in the background, reboot the machine, and run setup again.
If a file is locked, the
InstallValidate action is responsible for detecting this and displaying a dialog prompting the closure of the application which has locked the file. Make sure the "InstallValidate" action is listed in the Execute sequence by following these steps:
- Navigate to the Sequences view.
- Expand the Installation folder node.
- Expand the Execute sequence node.
- Verify that the InstallValidate action is listed after the CostFinalize action and before the InstallInitialize action.
- If the InstallValidate action does not appear in the sequence at the correct location, right-click on the InstallValidate action and select ''Move Up" or "Move Down" as needed to sequence it appropriately.
If the InstallValidate action does not appear in the sequence at all, right-click on the CostFinalize action, select Insert, and select the InstallValidate action from the list of standard actions to add it to the sequence. Make sure that you have selected Standard Actions in the Actions drop-down box to list the standard actions.
Note: In addition, make sure the FilesInUse dialog appears in the Dialogs view within the InstallShield IDE. If it does not appear, create a new sample project, export the FilesInUse dialog from the sample, and import it into the existing project.
D. The Microsoft Windows Installer Service is Not Installed Correctly
The Windows Installer Service is not properly installed or authored on the machine.
Ensure that the Windows Installer service is properly installed and configured. While Microsoft has regularly pushed updates which include new versions of MSI, it may be necessary to reinstall the engine on some systems.
E. The Windows Temp Folders are Full
The system temp directory is not clean. Either the temp directory does not have an adequate amount of space, or it has too many files that may conflict with setup files.
Clean the default temp directory and free up hard-disk space by removing unneeded files.
This is the temp directory that setup extracts files to and runs from. To access the default temp directory, launch the DOS prompt on the machine, type "Set", and hit enter. This displays the values of all the environment variables including TEMP. Make sure to clean the temp directory pointed to by the variable TEMP.
Since Windows 98, Microsoft has provided a Windows Disk Cleanup utility that assists in common cleanup tasks like emptying the Recycle Bin and removing Windows temporary files. Or, manually
Clean the Temp Directory. It may also be useful to defragment the hard-disk.
F. The Setup was Corrupted after Installation and, therefore, Fails with this Error During Uninstallation
Exit or turn off conflicting and competing programs; including such things as virus scanners, word processors, spreadsheets, web browsers and system utilities, etc. Then launch the installation again.
If this error occurs during uninstallation and the package appears to be in an undetermined state or still partially installed, use the Microsoft Windows Installer CleanUp utility to unregister the package's installation.
Once the installation package has been successfully uninstalled, then debug the project to determine what caused the original error.
G. An Older Version of InstallShield is Being Used
Upgrade to the latest version of InstallShield, as these types of errors have been known to occur more frequently in older versions.
H. General Error Occurred During the Installation
As this is a general error code, a more specific error may have occurred earlier in the installation process. Verbosely logging the installation can provide further information about the error's cause. Identifying the original error that occurred can help narrow down to the specific source of the problem. Additional information on logging an installation can be found in the following Knowledge Base articles:
Basic MSI projects: Logging an MSI Installation
InstallScript MSI projects: Logging An InstallScript MSI Project
It may be helpful to scan through the log file and identify any errors or warnings that may have occurred prior to error 1603. Additional information on errors and warnings that may appear in the log file can be found in the list of Windows Installer Error Messages or by searching Microsoft's resources for the particular error code.
Microsoft also provides a Windows Installer Verbose Log Analyzer utility which highlights and reports on the contents of the verbose MSI logs. This is just one of several installer utilities.
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In the Property table, there is a property called ISSCRIPT_ENGINE_VERSION. This is set to the IsScript version by the build engine. This version is compared to the version of iDriver.exe on the target machine and if iDriver.exe is less than ISSCRIPT_ENGINE_VERSION a Setup Is Unable To Find or Update ISScript.msi. Verify that the version of ISSCRIPT_ENGINE_VERSION is less than or equal to the version of iDriver.exe. If its greater than iDriver.exe, a newer version of the InstallScript engine must be installed on the target machine.
Note:iDriver.exe is located in appropriate version folder found in C:\Program Files\Common Files\InstallShield\Driver\<version>\Intel 32. IDriver.exe is used by versions of InstallShield older than InstallShield 12. In InstallShield 12 and later versions, ISSetup.dll is used instead.
I. File and Printer Sharing is Not Enabled or Was Not Installed When Installing Windows
Enable and/or install File and Printer Sharing.
J. Not Enough Disk Space
This error is known to occur on machines that do not have enough disk space to install the setup and store rollback files. This space is generally required on the root drive even if the setup may be installed to a different drive.
Make sure that you have enough space on the root drive of the machine. This space is required by setup to uncompress files in the temp directory and to store rollback information in the Windows directory of the machine. Even though the setup may be installed on another drive, its imperative that the machine have at least twice the space as the size of the setup on the root drive (the drive with the Windows operating system installed on it).
K. User Running the Setup Does Not Have Administrative Privileges
Some Windows Installer-based setups may require that you have administrative privileges. Make sure that you are logged in as the administrator on the machine.
L. The Folder or Drive that You are Trying to Install the Windows Installer Package to is Encrypted.
Install the package to a folder or drive that is not encrypted.
Additional Information
Having trouble installing software on your
home computer? Get the answers to your installation questions at
InstallShield's Consumer Central. The article on this page is for software developers.