pcdeveloper
Level 2

Please support redistributable (pre-requisite) for .NET 6 LTS

Jump to solution

Please support pre-requisite for .NET 6 LTS . My project use .NET 6 but InstallShiled 2021 did not support.

 

Download .NET 6.0 (Linux, macOS, and Windows) (microsoft.com)

 

Labels (1)
0 Kudos
2 Solutions

Please confirm which one you need,  

.NET Runtime 6.0.0 ?

View solution in original post

0 Kudos

First close installshield and then copy the attached prq files to the below location 

C:\Program Files (x86)\InstallShield\2020\SetupPrerequisites  (if you are using 2021 then change it to 2021 C:\Program Files (x86)\InstallShield\2021\SetupPrerequisites)

Then open installshield, go to redistributable view, and select check prq and it will ask for download Yes or no confirmation dialog, select YES for confirmation,  like shown in attachment, 

 

Once the download is complete, you can just build the project 

Once build is done, open the release location by click on "Open release Folder" button, 

Once disk1 folder is opened, you can install that setup.exe it will show the prq installation as first dialog, 

If you want add files to your project ism file, then click on files and folder and right click under "Destination Computer's Files" in right side panel and select add files, and select the files you want to add.

Hope it helps

Kind Regards,

View solution in original post

0 Kudos
11 Replies
pcdeveloper
Level 2
 
0 Kudos

Hi,

 Please try the attached prq for ASP .Net 6.0 and see it works for you or not. download and extract the attached zip file.

0 Kudos

Your file = .NET 6 for Desktop runtime + .NET 6 for ASP.NET Core runtime.

 

This is redundance. I appreciated your team higher, if you also supply only Pre-requisite (redistributable) just for .NET 6 for Desktop runtime 

 

0 Kudos
pcdeveloper
Level 2

Question 1: I am new to InstallShield, how to tell InstallShield know/import/install file ASP.NET Core Runtime 6.0 (x64).prq ?

Question 2: I use .NET 6 x64 runtime Windows Forms application, not ASP.NET Core . Are you mis-undertanding? I need it quite urgent, because my Windows Forms app use .NET 6 LTS.

0 Kudos

The screenshot you shared in first attachment was pointing to 5.0.3 ASP .net core, so taught you are expecting ASP .net core 6.0

0 Kudos

Attached is the new prq file for .NET Runtime 6.0.0 prq files, let me know if you have any additional questions or concerns. 

0 Kudos

Please confirm which one you need,  

.NET Runtime 6.0.0 ?

View solution in original post

0 Kudos
pcdeveloper
Level 2

Exactly what I want.

0 Kudos
pcdeveloper
Level 2

Because I am very new with InstallShield. Please guide me how to import/install file Microsoft .NET Runtime 6.0 (X64).prq what you given to me. I use BasicMSI project type.

0 Kudos

First close installshield and then copy the attached prq files to the below location 

C:\Program Files (x86)\InstallShield\2020\SetupPrerequisites  (if you are using 2021 then change it to 2021 C:\Program Files (x86)\InstallShield\2021\SetupPrerequisites)

Then open installshield, go to redistributable view, and select check prq and it will ask for download Yes or no confirmation dialog, select YES for confirmation,  like shown in attachment, 

 

Once the download is complete, you can just build the project 

Once build is done, open the release location by click on "Open release Folder" button, 

Once disk1 folder is opened, you can install that setup.exe it will show the prq installation as first dialog, 

If you want add files to your project ism file, then click on files and folder and right click under "Destination Computer's Files" in right side panel and select add files, and select the files you want to add.

Hope it helps

Kind Regards,

View solution in original post

0 Kudos

I follow your guide and success.

0 Kudos