cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
najnug_inias
Level 2

Facing issues based on Prerequisite editor on InstallShield

Problem : I want to check if my registry contains the MySQL Connector less than some specific value say 8.0.27.
 On running the installer, it is asking me for prompt even if I have 8.0.27 installed in the machine.

I tried a different scenario in which the condition was to check "Data on target system is not equal to specified data". It is still showing me prompt, even if I have 8.0.27 installed.

The condition I have used is:
1. for less than the specific data:
<condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MySQL AB\MySQL Connector/Net" FileName="Version" ReturnValue="8.0.32"/> 
2. for not equal to specified data: 
<condition Type="32" Comparison="32" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MySQL AB\MySQL Connector/Net" FileName="Version" ReturnValue="8.0.32"/> 

Both are not working, can anyone please help me look into this? 

THan

Labels (1)
0 Kudos
(8) Replies
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @najnug_inias ,

   Is it your own prq file, Created by your own.

Could you please share the prq file, let us check the prq file.

0 Kudos

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SetupPrereq>
<properties/>
<conditions>
<condition Type="32" Comparison="32" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MySQL AB\MySQL Connector/Net" FileName="Version" ReturnValue="8.0.27"/>
</conditions>
<files>
<file LocalFile="&lt;ISProductFolder&gt;\Objects\mysql-connector-net-8.0.27\mysql-connector-net-8.0.27.msi" URL="https://dev.mysql.com/get/Downloads/Connector-Net/mysql-connector-net-8.0.27.msi" CheckSum="A59E4C0B9FFD13AF7B931BC8EEB7B91F" FileSize="0,16117760"/>
</files>
<execute file="mysql-connector-net-8.0.32.msi"/>
<properties Id="{E5B9FCE7-E292-495D-B8BA-6F395D1D4724}" Description=""/>
<behavior Optional="1" MsiProgress="1"/>
</SetupPrereq>

0 Kudos

Hi @varul , I have shared the prq file. I have created this via Prerequisite Editor 

0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @najnug_inias ,

 

 Please try the attached prq file and verify it works or not, we have tested locally, it working as expected, 

make sure you copy the mysql msi file under setupprerequisites folder under installshield directory, refer screenshot.

Did my reply solve the issue? Please Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something?

And please Click "KUDO".

 

0 Kudos

 

Hi @varul , I tried this with 8.0.32, but still not able to get the needed solution, Attached is the same.
Let me know if there is something I am doing wrong.

0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

What do you mean by 8.0.32 png, 

Could you please explain your scenario, 

Is your machine is installed with 8.0.32 and your prq is different version included, 

Did you tried with the prq i have shared? if not please try with the prq i have shared

0 Kudos

Hi @varul 

Apologies for confusion, I have MySQL 8.0.32 installed in my system and I was verifying your shared prq by changing the version from 8.0.27 to 8.0.32.

For reference, I am trying to check in my installer, if there is 8.0.32 is installed, then no prompt should be there, if the connector is less than 8.0.32 or there is no connector, it should prompt to upgrade the installer.

0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Thanks for explaining the issue,

 I have investigated and found the issue is due to the registry value changes in 8.0.32 version 

The registry for 8.027 the registry path has / added after  MySQL Connector/NET

However in  8.0.32 the / option is removed and the registry has path MySQL Connector NET

which causes this issue, so you need to check for any other registry which is unique for both 8.0.27 and 8.0.32, or try with file exits with version option.

Refer the screenshot attached for your reference.

0 Kudos