cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
adeel_aziz
Level 3

DotNetCoCreateObject fails to load .NET 5 DLLs

Hi,

I have a DLL originally compiled in .NET Framework 4.7.1 which exposed some classes and methods using COM. I used DotNetCoCreateObject to create an instance and it was working fine.

However, I have recently migrated it to .NET 5 and not the InstallShield fails to load it with following error:

error number: 0x80040707 isrt._dotnetcocreateobject 
dll function call crashed
 
I am using InstallShield 2019 R3.
 
Can you please help me with this.
 
Reagrds,
 
Adeel Aziz.
0 Kudos
3 Replies
shunt
Revenera Moderator Revenera Moderator
Revenera Moderator

Installshield is probably still pointing to the previous .NET version files during your builds. Try specifying the .NET v5 files that Installshield can use during build time:

- Within Installshield select: Tools > ".NET" tab
- Here you can specify the .NET Framework File locations that Installshield should use.

There is more information here:
https://docs.revenera.com/installshield26helplib/helplibrary/IDlgOptions_NET.htm 

0 Kudos

Thanks for the reply. However, The .NET 5 is not installed in "C:\Windows\Microsoft.NET\Framework" location. It is installed in "C:\Program Files\dotnet".

Also, .NET 5 does not seem to have "Regasm.exe". Can you let me know how to handle COM DLLs compiled in .NET 5 in InstallShield?

 

Regards,

Adeel.

0 Kudos
SimonG
Level 5

Did you ever find a fix for this as I have the same problem with .NET dlls having converted from .NET 4.8?

Thanks in advance.

0 Kudos