cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sbepari79
Level 2

Custom action is getting executed at the time of uninstall

Jump to solution

 

I’ve created a simple installer and added few custom action within it, however while uninstalling, the custom actions are getting called and un-installation is getting failed.

I’ve even added condition Not Installed OR Installed

Labels (1)
0 Kudos
1 Solution
shunt
Revenera Moderator Revenera Moderator
Revenera Moderator

The condition that you are using will evaluate to True if its Installed or not installed so its expected that it would run during an uninstall.

Try just using "Not Installed" 

This should allow the custom action to run during first time installs but prevent it running running uninstalls.

Take a look at the following Conditions sheet if you need to add anymore conditions.

https://resources.flexera.com/web/pdf/archive/IS-CHS-Common-MSI-Conditions.pdf

View solution in original post

0 Kudos
1 Reply
shunt
Revenera Moderator Revenera Moderator
Revenera Moderator

The condition that you are using will evaluate to True if its Installed or not installed so its expected that it would run during an uninstall.

Try just using "Not Installed" 

This should allow the custom action to run during first time installs but prevent it running running uninstalls.

Take a look at the following Conditions sheet if you need to add anymore conditions.

https://resources.flexera.com/web/pdf/archive/IS-CHS-Common-MSI-Conditions.pdf

0 Kudos