yasinzaman
Flexera beginner

How to limit the license to an specific version of the software

Jump to solution

I'm using the FlexNet license genenrator (*.exe) and a license file template (*.lic) to manually generate licenses. Currently my license template (see below) allows all versions of the software. However, I need to limit the software version to 9.2 only. What keyword and value should I use in my license template to do that?

FEATURE ALL utsa 1.000 31-dec-2022 uncounted HOSTID=ANY \
SIGN="0091 ....."

0 Kudos
1 Solution
raffie
Intrepid explorer

The 1.000 in the template is the version number.  It corresponds to the version string used in the lc_checkout call.  So you would need to change that 1.000 to 9.2, and pass "9.2" in the lc_checkout call.  However, the version in the license file is an upper limit, not a fixed value.  So if you issue licenses with 9.3 or 10.9, the lc_checkout call with lower versions like "9.2" will still work.   If you really want to restrict it to only that version, you would need to change your feature name every time you change the version.

Also I hope you are not really using "ALL" as a feature name.  For your customers' sake you should use something more descriptive.

View solution in original post

2 Replies
raffie
Intrepid explorer

The 1.000 in the template is the version number.  It corresponds to the version string used in the lc_checkout call.  So you would need to change that 1.000 to 9.2, and pass "9.2" in the lc_checkout call.  However, the version in the license file is an upper limit, not a fixed value.  So if you issue licenses with 9.3 or 10.9, the lc_checkout call with lower versions like "9.2" will still work.   If you really want to restrict it to only that version, you would need to change your feature name every time you change the version.

Also I hope you are not really using "ALL" as a feature name.  For your customers' sake you should use something more descriptive.

View solution in original post

Thanks for your clarification!

0 Kudos