Kadimsr
Flexera beginner

Downloads for Flexera Flexnet Publisher

Hi Team ,
We have vulnerability issue on the versions of Flexera Flexnet Publisher (11.6.1 and lower ) . To remove this vulnerability we were asked to install Or upgrade the version to 11.16.2 or higher . 11.16.5 or higher is recommended. Could you please help me download the installabled for the software.
0 Kudos
9 Replies
aparashar1
Flexera Alumni

@Kadimsr , you will need to login to the Product and Licensing Centre, using your credentials and from there you can download the FNP GA toolkit.

URL: https://flexerasoftware.flexnetoperations.com/control/inst/login?nextURL=%2Fcontrol%2Finst%2Findex

You can also navigate to this page via "Get Support" drop down on the top of the Community page, there you should see the option for "Product and License Center User Administration".

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)

I am unable to register for an account. Could you please tell me how to register to the link provided below by you .

0 Kudos

Could you confirm if you have purchased the licensing rights/entitlements from Flexera? I tried investigating this, but i can see that your user account is created using 'gmail' ID, which can not be found in our active customer database.

If you/your company has any associated active entitlements from Flexera on SWM(/FNP), then kindly share the details on it and i will help you get the further details.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos

Hi, 

I'm posting here because I have a similar situation.  I have Citrix Licensing Server 11.16.3 build 29000 installed on a Win 2016 server.  This is the most recent version of Citrix licensing but it contains Flexera Flexnet Publisher in the form of  lmadmin.exe version 11.16.4  under "C:\Program Files (x86)\Citrix\Licensing\LS\". 

Our security software (Tenable Nessus Agent) detected this and flagged CVE-2019-8960 and CVE-2019-8961

I opened a support ticket with Citrix (Citrix Case#79471998) and they told me to download Flexera Flexnet Publisher license server manager and install it over the license server to resolve the issue.   What would I need to do this?   Do I need a paid Flexera account to download this bugfix for my installed Citrix product?

0 Kudos

@ScottRStelzer , i am not sure if you can be able to download the latest version of lmadmin (license manager) from the Product and Licensing Center (as you are not the direct prospect for FLexera) and this download operation would need an account mapped to you you or organisation - which is monetary.

Since, Citrix support mentioned about "downloading Flexera Flexnet Publisher license server manager and installing it over the license server to resolve the issue" - which i don't see a way to do without a paid account for yourself. Do you think it will be wise to have Citrix support shed some more light on "how to achieve this from your end"? - since it is them who recommended this workaround.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
sparekh
Flexera beginner

I have the same issue. Rockwell Automation Factory Talk includes Flexera Flexnet Publisher. I am unable to download this and upgrade to fix the vulnerability. Why can I not directly download this from Flexera and resolve the issue? Where is the download link to upgrade to 11.16.2 or higher?

0 Kudos

@sparekh , since you are using the 3rd party application i.e. "Rockwell Automation factory talk", hence even though you get the latest FNP toolkit - it will not help you.

The only way to resolve your issues with the application would be to either upgrade to a higher version of 3rd party application, which uses a latest FNP toolkit internally OR raise the query with Rockwell support and place a request for upgrade.

If you/your organisation have not purchased the licensing toolkit and entitlement for Flexnet publisher from Revener, you will not be able to download the GA FNP toolkits from Product and licensing center.

(If my response assists with your questions , then please click "ACCEPT AS SOLUTION" or 'Kudos' so that it help others.)
0 Kudos
pritpalkarir
Flexera beginner

Anyone managed to download and install latest version? We are having same issue. There are vulnerabilities on versions below 11.16.5 so we really need to update it asap. We use Autodesk products so not sure how to register product to Flexera so get to downloads. Any help will be apricated.  

0 Kudos

@Kadimsr Try to reach to Autodesk support and follow their guidance. 

Best Regards,
Mani. 

0 Kudos