cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
hungtrankim
Level 2

Getting "Not found" error when releasing the hang license with lmremove command

Hi,

I have followed the License Administration Guide to release the hang license but it doesnt works.
Could you please help me on this?

Steps to reproduce:
lmutil lmstat -c port@server  -f TEST_FEATURE

Users of TEST_FEATURE: (Total of 20 licenses issued; Total of 1 license in use)
"TEST_FEATURE" v5000, vendor: xxx, expiry: 01-aug-2025
vendor_string: xxx xxx xxx
floating license
testuser vm-1 vm-1-0 (v5000.0) (server/port 101), start Mon 9/5 2:17


Remove hang license with method 1:
lmutil lmremove -c port@server  TEST_FEATURE testuser vm-1 vm-1-0

lmremove: feature/user/host/display not found


Remove hang license with method 2:
lmutil lmremove -c port@server  -h TEST_FEATURE server port 101

lmremove: license handle 101 not found on this license server (server)

 

0 Kudos
5 Replies
mrathinam
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @hungtrankim Can you please share the license file as well?.

Best Regards,

 

Hi @mrathinam 

Thanks for your response. This is my license file

SERVER server MAC_ADDR port
DAEMON daemonsrv /test/bin/daemonsrv /test/daemonsrv.opt #(.opt -> log conf)
DAEMON daemonx /test/bin/daemonx /test/daemonx.opt #(.opt -> log conf)

#FEATURE FILTERED

FEATURE TEST_FEATURE daemonx 5000 01-aug-2025 10 ABCDEF \
	VENDOR_STRING="a b c" BORROW=123 SIGN="XXXXX XXXXX"

FEATURE TEST_FEATURE daemonsrv 5000 01-aug-2025 10 GHIKLM VENDOR_STRING="a b c"

#FEATURE FILTERED

 

systemctl status

Loaded: loaded (/etc/systemd/system/x.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2022-09-05 01:07:49 UTC; 8h ago
  Process: 1231 ExecStart=/test/bin/lmgrd -c /test/lic.dat -L /test/Logs/lic.log (code=exited, status=0/SUCCESS)
 Main PID: 1353 (lmgrd)
    Tasks: 9
   Memory: 12.3M
   CGroup: /system.slice/x.service
           ├─1353 /test/bin/lmgrd -c /test/lic.dat -L /test/Logs/lic.log
           ├─1355 daemonsrv -T server 11.16 7 -c :/test/lic.dat: -srv ifIixxx --lmgrd_start 6...
           └─1356 daemonx -T server 11.16 7 -c :/test/lic.dat: -srv ifIiwxxx --lmgrd_start 631...

 

0 Kudos

Hi @hungtrankim Please check the KB https://community.flexera.com/t5/FlexNet-Publisher-Knowledge-Base/lmremove-usage-to-return-a-checked-out-license-to-a-license/ta-p/3164 I think you are using -c but missing license file details, so can you try with license file (full path) and let me know the result.

Best Regards,

0 Kudos

Hi @mrathinam 

yes i have tried with full path and it returns the same error. (I also tried with LM_LICENSE_FILE).

 

$ lmutil lmremove -c /test/lic.dat -h TEST_FEATURE server 2000 101

lmutil - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
lmremove: license handle 101 not found on this license server (server)

The same with lmutil lmremove -c /test/lic.dat TEST_FEATURE testuser vm-1 vm-1-0

 

 I'm not sure why but I can get the feature info using lmstat -f

0 Kudos

Hi @hungtrankim Can you please raise an FNP support case for further investigation? Please. 

Best Regards,

0 Kudos