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Symptoms

FNMS agent based Oracle introspection scan fails to generate an Oracle inventory file, and the tracker.log file (found in either %TEMP%\Managesoft\ directory or C:\Windows\Temp\Managesoft) displays the following debug output -

[11/2/2016 9:12:35 AM (G, 0)] {8440} Executing oracle inventory rules
[11/2/2016 9:12:35 AM (G, 0)] {8440} WARNING: Configuration properties for the Oracle home "D:\oracle\product\11g\db" could not be discovered and instances in this home will not be inventoried.
[11/2/2016 9:12:35 AM (G, 0)] {8440} ===== Discovered Oracle database instances and listeners
[11/2/2016 9:12:35 AM (G, 0)] {8440} +-- "D:\oracle\product\11g\db": Discovered by = Process,Service,Registry,Rule, DBA group = "ora_dba", Has SQLPlus = true, SQLNet Authentication Services = "NTS", Can Inventory = false
[11/2/2016 9:12:35 AM (G, 0)] {8440} |   +-- Instance "ORCL": Discovered by = Process,Service,Registry, Process ID = 10212/10212, State = running
[11/2/2016 9:12:35 AM (G, 0)] {8440} |   +-- Listener "LISTENER": Discovered by = Service
[11/2/2016 9:12:35 AM (G, 0)] {8440} Oracle home environment information was not discovered.
[11/2/2016 9:12:35 AM (G, 0)] {8440} Finished tracking Oracle database instances using inventory recognition rules

Cause

Check the $ORACLE_HOME\Admin\Network directory to see whether the TNSNames.ora file exists. Although the agent does not use the information in this file to perform the Oracle scan, it still must reside in the expected directory in order for the agent to connect to the database instances.

Resolution

Create an empty tnsnames.ora file in the $ORACLE_HOME\Admin\Network directory.

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Version history
Last update:
‎Mar 07, 2022 05:10 AM
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