cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

FlexNet inventory agent not reporting after installation or events do not run as scheduled.

Symptoms

The Installation.log and Policy.log show a failure not being able to connect to the Beacon due to a Network Firewall, SSL Certificate/Revocation error or Proxy settings not configured.
The failure was fixed and the Agent is still not running or uploading an inventory.

These logs by default are created at:

  • Windows Agents installed by the Local System account: C:\Windows\Temp\Managesoft
  • Windows Agents installed/reinstalled by a User: C:\Users\UsernameGoesHere\AppData\Local\Temp\Managesoft
  • Non-Windows Agents: /var/opt/managesoft/log

 

Cause

By default, once the Policy Download fails during the installation, the Agent would not have a schedule to run on since it never received its policies and schedules from the Beacon.

Resolution

Instead of reinstalling the Agent, you can attempt to download the Policy again if your Deployment Server was already set in the bootstrap file initially (mgssetup.ini or mgsft_rollout_response).

Downloading the Policy for the Agent can be done by executing mgspolicy -t machine command, and binaries for mgspolicy are located in the following folder:

  • For Windows: C:\Program Files (x86)\ManageSoft\Policy Client (for 64-bit machines) or C:\Program Files\ManageSoft\Policy Client (for 32-bit machines)
  • For non-Windows: /opt/managesoft/bin
Was this article helpful? Yes No
100% helpful (2/2)
Comments
raghuvaran_ram
By
Level 6

Hi

In my case the agent reported only once after the fresh installation and not after that. 

I triggered C:\Program Files (x86)\ManageSoft\Schedule Agent>ndschedag.exe -t machine and it is showing the tomorrows date. However when I checked in

C:\ProgramData\ManageSoft Corp\ManageSoft\Common\Uploads\Inventories

this folder is empty and 

C:\ProgramData\ManageSoft Corp\ManageSoft\Tracker\Inventories 

it showing only the file dated when it last communicated and not the latest file, which means the inventory file (.ndi) is not generating, Please let me know what I need to check and why inventory file is not generating. I have the same issue for around 80 Servers, we are using FNMS 2020R1 and the agent version is 13 

stefange
By
Level 6

Hi, the files are automatically uploaded to the beacon server if you set upload=true. I would recommend checking the tracker.log and installation.log (C:\Windows\temp\Managesoft). Also a restart of the two related Windows Services fixes a lot of issues.

Please make sure the services are running and that the installation.log/tracker.log do not contain an error message.

Stefan

 

x-dkshasau
By
Level 3

In my case, agent is not getting installed after running the setup with administrative privileges'. There are no changes have been made to setup or the Beacon. Many of the times, logs are not generating as well. 

 

Can someone please suggest what I should do next?

cartejam
By
Level 5

its would be a suggestion, as i am seeing after installation of the agent on linux recently, that the agent should poll for the policy.

Please can you confirm if after installation of the RPM package to linux, if the service will attempt  a further poll to collect the policy or does it only attempt to get the policy during installation and then not again.

Thanks

dsalter
By
Level 6

Often when I find agents failing to report after installation, I find that firewall blocking was the cause of the issue and I needed to open ports between the two subnets to assure good communications.

You can check that using a combination of pings, telnet and ssh to your Beacon server on the port it is listening, typically 80 or 8080 

winvarma
By
Level 10

Hi

We freshly installed agent on a windows server 2019 and the installation is successful without any errors. Verified all the logs and did't find single error and its been 2 days but still the server is not reflecting in all inventory. We tried uninstalling the agent but its getting stuck and not proceeding further and no scope to reinstall the agent. Please suggest any other troubleshooting steps .

stefange
By
Level 6

Hi,

The first check you should do is run the ndschedag -t machine in C:\program files (x86)\Managesoft\schedule agent\ in an elevated commandline. You should see 4 or 3 schedules depending on the agent version.

With right mouse click on Generate Inventory, you can trigger an inventory gathering. Validate the outcomes in the tracker.log and uploader.log (uploader.log is only used if upload=false was specified, otherwise upload occurs in the tracker.log)

My guess, the schedule of your inventory in the settings did not occur yet.

Stefan

winvarma
By
Level 10

hi We have run the policy clients many times and we didn't face any issue and will that not trigger inventory gathering?

kclausen
By
Flexera Alumni

@winvarma - No, a newly installed agent does not gather inventory until the next scheduled event.  For example, if the Inventory Settings Page has your inventory schedule set to run every Saturday, then if you successfully install an agent on Monday, it does not perform the first inventory until Saturday.

Version history
Last update:
‎Nov 01, 2021 06:48 AM
Updated by: