Some users may have issues creating a community account. For more information, please click here.

daniel_klein
Active participant

Wrong server name in upload/download settings

Jump to solution

Hi everyone,

I've installed FNMS on our customer site using http for communication - everything works fine. Later we changed the communication to https. After i installed the agent on a windows server the policies where loaded BUT the upload and download locations are still the old server name. The certificate name is flexera.123.local, but the policy uses the servername. I have set up everything in FNMS (re run the ps scirpts too), the beacon and the agent for secure communication via the DNS name flexera.123.local. However, as soon as the agent has pulled its upload and download settings from the beacon via the policy, the server name C12345D6 is stored as the host, which means that communication does not work.

I think it's just one little configuraiton i missed. Hope someone may help me.

Thanks

Daniel

1 Solution

As @erwinlindemann notes, the details in the Beacon table in the compliance database can be checked to see what name is used.

If you find the old (unwanted) beacon name is appearing there, check the following article for guidance on how to configure the networkName setting in the BeaconEngine.config file on your beacon to change it: How to configure the beacon to use a different name or alias than its host name

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post

3 Replies
erwinlindemann
Consultant

Hi Daniel,

Most likely, you will have to update the Beacon failover settings in the [FNMSCompliance] database . These failover settings are stored in the [Beacon] table in the [HTTPAccessData] column (in XML format).

See the following article, please: How are the failover settings built for FlexNet inventory agents?

After updating the failover settings, the correct Beacon server names and download protocols should be stored in the 'BeaconPolicy.xml' file downloaded by your Beacon(s). These settings will be picked up by the Flexera agents, too.

As @erwinlindemann notes, the details in the Beacon table in the compliance database can be checked to see what name is used.

If you find the old (unwanted) beacon name is appearing there, check the following article for guidance on how to configure the networkName setting in the BeaconEngine.config file on your beacon to change it: How to configure the beacon to use a different name or alias than its host name

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post

daniel_klein
Active participant

thanks to both of you @ChrisG and @erwinlindemann 🙂 now it works

0 Kudos