junaid_vengadan
Level 7

SSL error in UNIX inventory agent -

Hi,
 
We are getting below error when uploading data to beacon from inventory agent after the installation of agent.
 
We are using SSL in beacon server connectivity 
 
[Mon 20 Apr 2020 01:38:57 PM +04 (N, 0)] {2738} Error 0xE1BBFC14: OpenSSL error 0xFC14: unable to get local issuer certificate
[Mon 20 Apr 2020 01:38:57 PM +04 (N, 0)] {2738} Error 0xE050044D: Failed to create remote directory /ManageSoftRL
[Mon 20 Apr 2020 01:38:57 PM +04 (N, 0)] {2738} Error 0xE0690099: Specified remote directory is invalid, or could not be created
[Mon 20 Apr 2020 01:38:57 PM +04 (G, 0)] {2738} ERROR: Remote directory is invalid
[Mon 20 Apr 2020 01:38:57 PM +04 (G, 0)] {2738} Upload failed due to a server side issue.  This server may be retried during this upload session.
 
 
0 Kudos
6 Replies

Hi,

did you create and deploy the mgst_rollout_cert file before installing the agent to a unix device?

Details: p. 77, p.85

https://docs.flexera.com/FlexNetManagerSuite2019R2/EN/WebHelp/PDF%20Documents/On-Prem/GatheringFlexN...

Best,

Dennis

Hi,

Thanks a lot for the help !!

yeah , i missed the step mentioned .

Will try this out once 🙂

 

Regards,

Junaid Veangadan 

Hi Dennis,

The installation was successfully done after i follows SSL certificate part.

Unfortunately due to some infra challenges , i had to change CheckCertificateRevocation=false in config.ini

what is the best practice if i want to change entry in config.ini of multiple linux endpoints centrally ?
0 Kudos

@junaid_vengadan - If you have an updated CONFIG.INI file, you can push it out to a set of target servers with a tool such as Chef, Puppet, or Ansible.

Sure will follow this 

thanks a lot 

0 Kudos
raghuvaran_ram
Level 6

@dennis_reinhardt @kclausen 

I have the same issue in azure, we are trying to install and retrieve information through Kubernetes agents and I'm getting this below error.

The server prioritization is completed and when it's trying to upload .ndi we are getting the below error.

[Tue Nov 30 05:12:47 2021 (N, 0)] {114} Error 0xE1BBFC14: OpenSSL error 0xFC14: unable to get local issuer certificate
[Tue Nov 30 05:12:47 2021 (N, 0)] {114} Error 0xE050044D: Failed to create remote directory /ManageSoftRL
[Tue Nov 30 05:12:47 2021 (N, 0)] {114} Error 0xE0690099: Specified remote directory is invalid, or could not be created
[Tue Nov 30 05:12:47 2021 (G, 0)] {114} ERROR: Remote directory is invalid

In our on-prem we have defined set FALSE for both CheckServerCertificate & CheckCertificateRevocation in the setup file, is there an option I can change in the YAML file too

0 Kudos