Some users may have issues creating a community account See more here.

nagaeendra
Intrepid explorer

FNMS Inventory Agent config corrupt

Jump to solution

Hi,

Wondering as what is causing the config.ini file to corrupt/ missing entries which are needed for the agent to work as expected and not be Out of Date Agent. 

what i have observed is it will not have any Beacon entries like Download /Upload

2 Solutions
kclausen
Flexera
Flexera

On Linux/UNIX, this may happen if the mgsft_rollout_response file is not properly configured when installing the agent:

This file must be:

1) Pre-configured with a valid Beacon URL

2) Before running the agent installation package, this configured file must be placed in the /var/tmp folder.

Another potential issue is that this file must be in UNIX format (without CR/LF at the end of each line).  If you edit this file on a Windows computer, the text editor that you use may convert the file format into Windows.  You should use a utility such as NotePad++ on Windows, or edit the file on a Linux computer with a native Unix-like text editor.

View solution in original post

@nagaeendra - I have not seen this issue before, and if you haven't yet done so, I would recommend that you open a Support Case to engage with a technical support engineer to help you troubleshoot.

View solution in original post

11 Replies
kclausen
Flexera
Flexera

On Linux/UNIX, this may happen if the mgsft_rollout_response file is not properly configured when installing the agent:

This file must be:

1) Pre-configured with a valid Beacon URL

2) Before running the agent installation package, this configured file must be placed in the /var/tmp folder.

Another potential issue is that this file must be in UNIX format (without CR/LF at the end of each line).  If you edit this file on a Windows computer, the text editor that you use may convert the file format into Windows.  You should use a utility such as NotePad++ on Windows, or edit the file on a Linux computer with a native Unix-like text editor.

View solution in original post

Hi @kclausen 

I am afraid that don't not seem to be the case, as those specific agent would be communication as any other working agent, uploading ndi file etc, but happens much later with out any pattern as such on a random  time frame.

 

0 Kudos

Hi @kclausen , 

Further to the previous update, after the install all these agents were and will work fine, this corruption of the config occurrence is random in our case, can happen to any device, also happens on Windows, where in registry entries for Upload and download will be lost and those agents would be out of date inventories .

0 Kudos

@nagaeendra - I have not seen this issue before, and if you haven't yet done so, I would recommend that you open a Support Case to engage with a technical support engineer to help you troubleshoot.

View solution in original post

Hi Kclausen,

I have raised support case but it's not moving anywhere. how to go about this now.
This is how the corrupt config.in looks
"
[ManageSoft]

InstallDir=/opt/managesoft
ETCPInstallDir=/opt/managesoft
CommonAppDataFolder=/var/opt/managesoft
ETCPVersion=14.0.0

[ManageSoft\Schedule Agent\CurrentVersion]

Catchup=
CurrentUserSchedule=
Disabled=False
DisablePeriod=3600
EventNetType=3
LogFile=$(CommonAppDataFolder)/log/managesoft.log
LogLevel=A-z
LogModules=default
LogMsgCatPath=
LogFileOld=$(CommonAppDataFolder)/log/managesoft.old
LogFileSize=4000000
MachineScheduleDirectory=$(CommonAppDataFolder)/scheduler/schedules
UserScheduleDirectory=$(AppDataFolder)/.managesoft/scheduler/schedules
CurrentMachineSchedule=
MachineId=$(MachineName)
NativeScheduler=ndtask
UserId=$(UserName)
HideMachineUI=True
RetryPolicy=True
RetryPolicyCommand=mgspolicy -t Machine -o UserInteractionLevel=Quiet
ApplyPolicyIfLoggedOn=True
UnixTaskSchedulerSocket=$(CommonAppDataFolder)/run/MGS.RemoteTaskScheduler.1.sock

[ManageSoft\Launcher\CurrentVersion]

http_proxy=
https_proxy=
no_proxy=
AlertExecute=False
AutoAlertExecute=
VirusScan=False
VirusScanCommand=
VerifyFilesSigned=False
VerifyCatalogSigned=False
VerifyTrustOrSign=False
CacheDirectory=
PkgCacheDirectory=
LogFile=$(CommonAppDataFolder)/log/managesoft.log
LogFileBak=
LogFileOld=$(CommonAppDataFolder)/log/managesoft.old
LogFileSize=4000000
DownloadOnly=False
NoStage=False
UninstallString=
BaseURLAlgo=First
ServiceConnectTimeout=20
ServiceCreateTimeout=30
NetworkTimeout=30
UserInteractionLevel=Full
PublicAppAccess=FullAccess
PrivateAppAccess=FullAccess
NetworkRetries=1
NetworkRetryPeriodIncrement=0
MaximumNetworkRetryPeriod=300
ConnectionAttempts=2
RotateConnectionsOnFailedConnectionAttempt=False
NetworkSense=False
NetworkMinSpeed=1
NetworkHighSpeed=0
NetworkLowUsage=100
NetworkLowUsageLowerLimit=100
NetworkLowUsageUpperLimit=100
NetworkHighUsage=100
NetworkHighUsageLowerLimit=100
NetworkHighUsageUpperLimit=100
NetworkMaxRate=0
NetworkMaxByteLevelSpeed=262144
AllowByteLevel=True
ServerAuthentication=
BaseURLDll=
UIMsgCatPath=
LogLevel=A-z
LogModules=default
LogMsgCatPath=
LogFlags=
LogType=Auto
PluginDirectory=/opt/managesoft/bin/plugins
SelfUpdateURL=http://www.managesoft.com/software/netdploy/download/ndlaunch.osd
CheckRegistry=False
ForceCOMRegistration=False
ForceValidSignature=False
DisplayAllAuthcode=False
AskAboutDependencies=False
AskBeforeInstalling=True
PromptOnInstallCompletion=False
PromptOnUninstallCompletion=False
AutoPromptOnInstallCompletion=
AutoPromptOnUninstallCompletion=
CmdLineOverrides=False
AddRemove=Default
RemoveNDAppsGroup=
SupplyWorstCaseReturnValue=False
MigrationState=
SaveAllUserSymbols=False
RetainMachinePrefs=
RetainUserPrefs=
DiskReservedKB=
PromptOnCOMRegFailures=True
AutoRedundancy=True
QuietUntilUpdate=False
ShowIcon=
ConfirmSharedFileRemoval=True
GenerateComplianceLog=
ReportCompliance=
PostponeUserInteractionLevel=Full
PostponeByDefault=False
SplashScreenFile=
RebootIfRequired=False
AlwaysDisplayReboot=False
UITimeoutWait=300
RenotifyTimeout=240
ForceReboot=False
ForceRebootIfLocked=True
AllowRebootIfLocked=False
AllowRebootIfServer=False
SecurityPatchRebootIfRequired=True
ForceSharedFileRemove=
LowProfile=
PropagatePkgChanged=False
UninstallIShieldSilently=Auto
UseLastUpdateLocation=False
PolicyServerPriority=50
DetectApplicationVersionConflicts=True
StageInactivePackages=False
RebootPath=$(ProgramPath)/reboot
RebootCmdLine="$(RebootPath)"
FileFilters=
NeverMoveOnReboot=False
InstallationStatusRefreshPeriod=604800
ReInstallRequiresVersionChange=True
RebootPromptCycles=0
RebootPromptUnlimited=false
RebootPromptWait=600
AllowTimeoutIfLocked=true
RebootPreCommand=
RebootPostCommand=
RebootContinueAfterCmdFailure=true
RebootForceWindowToTop=false
RebootShowShutdown=false
DisableUninstallBehaviour=False
PostponementQueryBefore=Download
PostponePath=$(ProgramPath)/mgspostpone
PostponeCmdLine="$(PostponePath)"
PolicyStep=Install

[ManageSoft\AgentUniqueID\History]

History01=AAAAAQAAABIAAAAKAAAAAAAAAAAAAAAPAAAAAGUzMDQzOTE1ZGEyNDZmOWM0NjAxOTY0NjM1YzkwNTY4NjdmMzYyMWNkNTg3YzQwODQxZmNmZGNhNTU3Njk5ZDQwWDgwMDAxNjhGMUY5MDAwMUVhMDFzZmNkYjJhMjAyMTAzMjFUMTQwNjAxAAAAAA==
Count=1l

[ManageSoft\AgentUniqueID]

AgentUniqueID=e3043915da246f9c4601964635c9056867f3621cd587c40841fcfdca557699d4

[ManageSoft\Tracker\CurrentVersion]

Generation=Full
"
0 Kudos
this is all the config info, those agents would contain
0 Kudos

@nagaeendra - This seems like an older version of the agent?  Are you trying to perform some type of "upgrade" of your agents to a newer version?  

Since this Community Post has been set to "Resolved", I would recommend that you create a new Community Post to get some feedback from other community members.

0 Kudos

Hi @kclausen ,

This is a 2019 R2 agent and no activity is been performed on this, it was working fine and this is just sample of one of the device, it  is not a version or platform specific this is the general trend when an agent is out of date.

I am trying to do a auto healing of such agents, initially  i thought it was just missing Download and Upload server info and was able to get them updated but, since the config file is missing other part it generates inaccurate ndi file.

So wondering if there are any set of minimum config setting which needs to be there for the agent to work as expected. 

And sorry about this post post been resolved, unfortunately it was presumed that what was shared was a solution for my issue, but it was not as you are seeing . 

0 Kudos

Hi @nagaeendra ,

Did you try to uninstall and to install again the agent, some time this operation is more helpful as trying to fix it.

0 Kudos
Hi @adrian_ritz1,
Yes, if we reinstall it works. but that is sometime which needs lot of coordinating efforts apart from ticket logging etc as we don't have access to all those devices to do it. that's where we are exploring Auto-heal approach.
0 Kudos