gvirgili
Level 2

Cognos Upgrade - FNMS 2020-R2

Hi all,

I try to upgrade the new version of Cognos form 11.0.6 to 11.0.13, that is needed from flexnet manage 2020-R2.

We perform the upgrade without issue in the not production environment but we have in the production environment.

When we lunch the following command ".\InstallCognos.ps1" on powershell as administrator appear this issue:

Using J_HOME: ..\jre
Using J_OPTS:
Cognos configuration failed (error code 9). Check the cogconfig.*.log and cogconfig_response.csv files found in
D:\Program Files\ibm\cognos\analytics\logs for more information.
At D:\Cognos\Support\modules\ConfigureCognos.psm1:273 char:4
+ throw "Cognos configuration failed (error code $LASTEXITCODE). Check the cogc ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (Cognos configur...re information.:String) [], RuntimeException
+ FullyQualifiedErrorId : Cognos configuration failed (error code 9). Check the cogconfig.*.log and cogconfig_resp
onse.csv files found in D:\Program Files\ibm\cognos\analytics\logs for more information.

 

Someone can help me to understand the issue?

thanks a lot

0 Kudos
4 Replies
kclausen
Level 14 Flexeran
Level 14 Flexeran

@gvirgili - Have you looked at the Log Files mentioned above?

Check the cogconfig.*.log and cogconfig_response.csv files found in
D:\Program Files\ibm\cognos\analytics\logs for more information

@kclausen  - Yes, I checked those files and in particular in the file "cogconfig_response.csv" I found this error message: ERROR, "[Encryption]", "CAM-CRP-1114 Could not find the self-signed certificate of the certificate authority with alias 'ca' in the keystore 'D:/Program Files/ibm/cognos/analytics/configuration/certs\CAMKeystore'."

I don't know how to edit the CAMKeystore file and to solve this problem

0 Kudos
kclausen
Level 14 Flexeran
Level 14 Flexeran

@gvirgili - That seems to be a very specific error within Cognos, you can try to google that error for more information, but it is likely that you will need to engage with Support for help with this.  

Are you sure that your Cognos Service Account is a full local admin and you are running your Upgrade process logged into the server with an account that is also a full Local Admin to the Windows box?

0 Kudos

@kclausen - I tried re-opening the IBM Cognos Configuration program and I  solved it. Thanks for the support anyway