cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Citrix Virtual apps import

Hi,

Trying to run the Xenapp server agent - not using a staging database so running the app with the

-url

-user

-pass

switches and am getting an error message

system.indexoutofrangeexception: Index was outside the bounds of the array

Any ideas out there please?

0 Kudos
16 Replies
ChrisG
Community Manager Community Manager
Community Manager

Is there any further context that appears before or after this error message?

(Ensure the "-v" command line option is used to produce verbose output, in case that gives any further details beyond what you are already seeing.)

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

Hi, thanks please see attached.

0 Kudos

That error smells like it might occur if bad command line options are provided. What is the full command line you are using?

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

url = FQDN of the beacon

user = service account in use on the beacon

pass = service account password

0 Kudos

As is shown in the guide

FnmpXenAppAgent.exe
-url http://beacon01.example.com -user beaconAccountName -pass password

0 Kudos

So I assume the screenshot shared earlier was generated when using the "-v" command line option, but that option isn't shown in the command line above.

I should have been clearer that the "-v" option needs a number (specifying a verbosity level) after it - and if a number was not specified, that would explain the error you saw in that case. But it wouldn't explain the error seen when the "-v" option is not used.

Can you share a screenshot showing the exact full command used (including details such as exactly where spaces are and are not specified) and the full output it generates (obviously with sensitive details obscured)?

NB. An "IndexOutOfRangeException" from the CommandLineProcessor.Initialize function like shown in the screenshot indicates that a command line option where it expects to find a value following the option didn't have a value specified.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

Thanks - what is the best -v number (and required format) to use to get the most accurate result please?

0 Kudos

Use "0" to include the most verbose details that are available:

FnmpXenAppAgent.exe -v 0 -url http://beacon01.example.com -user beaconAccountName -pass password
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

MicrosoftTeams-image (4).png

0 Kudos

MicrosoftTeams-image.png

0 Kudos

So I'm confused at what you're seeing. 🙂 There is no error shown in this screenshot. Has the problem stopped happening? Or if it is still occurring, where are you seeing the error?

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

MicrosoftTeams-image (3).png

0 Kudos

So the command line with "-v" at the end is failing due to no number following the option.

The other command lines are not obviously showing any failure. So I'm guess I'm not sure what problem you are seeking input from the Community on here. Is there still an issue that is concerning you?

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

So if there is no error shown that means the agent has run ok?

Have you seen the other reply above using the format you suggested? That doesn't report any error.

0 Kudos

From what you're reporting now, the system.indexoutofrangeexception that is the focus of your question in this thread seems to be no longer be occurring.

I don't know exactly what output to expect from this agent. But unless an error is reported, I would assume that the agent is running OK until/unless you observe some kind of anomaly.

The following page contains some suggestions for validation of what the agent is doing: Validation and Problem Solving.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

Is there anything else I need to do to set this up on the XenApp server?

0 Kudos