winvarma
Level 10

AWS servers hosted in is showing on-premise by FlexNet Inventory agent

Hi Forum,

We have few servers hosted in AWS and the FlexNet inventory agent is installed for gathering inventory. We are observing that few of the servers show us alert the the Virtual machine does not have a host and the VM properties under the device properties show host affinity enabled, and it doesn't display cloud hosting property, it doesn't display under the cloud  service provider inventory as well and it shows its hosted on premise.

Please suggest identifying the cause and remediate this and we are on Prem 2020 R1, thanks

Regards,

 

0 Kudos
9 Replies
mag00_75
Level 7

Hi @winvarma 

During the inventory process the agent ask the AWS API about it's own instance id. Its that little extra thing that from my understanding tells FNMS that the EC2 is actually hosted in AWS.

Inventory Adapters and Connectors Reference FlexNet Manager Suite 2021 R1 - Appendix 3: Enhanced Inv...

kclausen
Flexera
Flexera

@winvarma - Do you have other sources of inventory for these AWS instances?  Population of the Hosted In attribute is only set by the Flexera Agent.

If you look at the History tab of one of these instances, do you see the Hosted By field being changed by something?

0 Kudos

Hi @kclausen ,

we have only FlexNet inventory agent for inventory gathering and we don't have other source of inventory for AWS hosted servers and there is no Hosted by option available in the whole history for servers where this issue exists.

0 Kudos

OK, @winvarma.  I don't have any other ideas unless those specific instances have an older version of agent that did not capture the Hosted By field.

0 Kudos

hi @kclausen , we are using FlexNet agent version 15.0 and let me confirm as we have other version of agents like 12.4 which might be installed on these servers and if that is the case i will upgrade the agent to latest version.

Thank you

Regards

0 Kudos

Hi @winvarma v16.3 I believe was the first version that was able to interrogate the AWS API. 

As that version has been depreciated, all v17 agents support interrogating the AWS API for EC2 instances.

@kclausen  with the AWS API that Flexera calls > 

Do you know if that is an AWS default field ie can it be switched off? We have a separate issue where a handful of devices don't retrieve their correct status, we believe it's because they cannot connect to the 169.254.169.254 address, but we're not able at this time retrieve logging to determine whether this is the root cause. 

0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

@bmaudlin - it is possible that access to the Amazon EC2 metadata service is blocked in some way. For example, firewall settings on the instance could be configured to block access - see https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/instancedata-data-retrieval.html#instance-metada.... I expect something like that would likely defeat the FlexNet inventory agent's ability to get instance metadata to be able to identify the cloud service provider for the instance.

Take a look in the inventory agent log (tracker.log) - this may give some insight into whether the agent has been able to connect to the metadata service.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos
mag00_75
Level 7

@winvarma Have you tested to logon to the EC2 and execute the api to see if you can fetch the instanceID manually? Could be that your EC2 do not have the rights to call the service to get its instanceID

0 Kudos