paromita_deb2
Level 4

ARL and PURL File is not updating manually when we try to run in manual

Hi Team,

When I try to run the ARL and PURL file manually in ON-Prime prod environment. date is updating but version is not updating.

Please find the attached screen shot.

The same is working ARL,PURL,SKU files are working in Test Environment.

Please help on this issue. No error message in the log file

Regards,

Dhananjayan

0 Kudos
28 Replies
durgeshsing
Level 7

Hi

Please confirm if you have installed application on E drive.

0 Kudos

Hi,

Yes the it is in E drive only. "E:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\DotNet\bin" mgsimporter.exe 

Regards,

Dhananjayan

0 Kudos

Hi

Can you share Recognition.log from below path  

E:\ProgramData\Flexera Software\Compliance\Logging\Content

0 Kudos

Hi,

We dont have this path in that drive E drive. We will see the file as reader log and writer log. i have attached those logs for reference.

Regards,

Dhananjayan

0 Kudos

Please check in C drive . This is hidden drive so ensure you have enable setting to see hidden folder.

0 Kudos

Yes, the correct folder name for the Recognition Import Logs would be:

C:\ProgramData\Flexera Software\Compliance\Logging\Content

0 Kudos

Hi,

Please find the attached required logs files.

 

Regards,

Dhananjayan

0 Kudos

Hi 

Are you not able to see below version

ARL
Version: 2634

0 Kudos

Hi,

I am not able to see the below version it is still 2631 and also in PURL 487 version, at present for that also it is 491 version.

we dont have any problem in test environment and it is updating correctly.

Regards,

Dhananjayan

0 Kudos

When did you last restarted the server . If not recently , can you restart & reinitiate the process.

0 Kudos

Hi,

Last restart happened one month before,

 

Regards,

Dhananjayan

0 Kudos

@paromita_deb2 - Your log files show that the import was successful.  If you are not seeing the latest ARL and PURL builds from your manual import, then my only guess is that you are not importing the most recent ARL and PURL libraries.  I would recommend that you manually download the latest versions of each library down to your server and then perform another import.

0 Kudos

Hi,

Same files are correctly working in test environment but is not updating in Prod environment.

Regards,

Dhananjayan

0 Kudos

Can you try a restart of server & then check again.

0 Kudos

Hi,

This week patching activity scheduled for the server once completed patching team will restart the server. we will check after the activity.

Regards,

Dhananjayan

0 Kudos

Hi,

Saturday server restarted successfully. today i done manual ARL,PURl,SKU upload but SKU only success. PURL and ARL not updating the version.

ARL file runs completed successfully, but date also not updated. i have attached the screen shot please help me on this. Verified the logs no errors.

 

SKU version new version is 493- Updated successfully

Purl Version new version is 493- Date updated but version not updated.

ARL new version is 2635- DATE and version not updated.

But the same files updated successfully in test environment.

Regards,

Dhananjayan

0 Kudos

Hi,

Again i have tried manual only today. we have customize environment so unable to run automatic.

I have run this command -ia for arl and -is for purl and sku. still problem.

Please suggest any help.

Regards,

Dhananjayan

0 Kudos

@paromita_deb2 - What version of FNMS On-Premises is this?  The -ia and -is parameters have not been used in FNMS for some time.

Stage the Libraries
Place the ARL file into C:\ProgramData\Flexera Software\FlexNet Manager Platform\DataImport\Content\ARL

Place the SKU and PURL library files into C:\ProgramData\Flexera Software\FlexNet Manager Platform\DataImport\Content\SKU

Launch the Import

In a DOS Prompt (run As Admin) go to the FlexNet Manager \dotnet\bin folder.

Launch the full import with the following command:

ShadowHostWin.exe BatchProcessTask.exe run ARLImport

0 Kudos

Hi,

We dont have folder only upto data import folder is available. Shall i create a another 2 folders and move the ARL,PURl,SKU files in those folder?

Please confirm.

After this i need to run whole command like

"ShadowHostWin.exe BatchProcessTask.exe run ARLImport".

We are using the FNMS2020 R1 version in On-Permises.

Please let us know so that i can try this workaround.

The same is working fine in test environment. i dont have idea why it is not working in prod environment.

Regards,

Dhananjayan

0 Kudos