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Summary

If administrator access to the admin site has been lost, for whatever reason, it is possible to set admin permissions back to the default settings.

Symptoms

If the message "You do not have access to this area" is displayed when trying to access the App Portal admin site, even though the logged in user has admin permissions, then it is possible that the permissions may have been corrupted or changed inadvertently.

Cause

This issue is caused by having an invalid AD user GUID in the WD_NodeSecurity table. This may occur if a user who previously had admin permissions is deleted from Active Directory.

Resolution

The attached web service may help to identify which GUIDs might be bad.. Based on the GUIDs that are found, an attempt can be made to selectively cleanup the bad guids from the WD_NodeSecurity table, without deleting all records.. To use this web service, copy the attached ValidateSecurityGUIDs.asmx to the web/ws folder under the App Portal install directory.. Once you have done this, hit the following URL in a browser:

http://localhost/esd/ws/ValidateSecurityGUIDs.asmx

Invoke the function named FindInvalidAdminSecurityGUIDs

This will display a list of GUIDs which can not be looked up in AD. This would typically indicate that they are bad.. The list will be displayed in the browser, and also in the log file named badGUIDS.log.. For each guid in the list, run the following query against the App Portal DB:

delete from wd_NodeSecurity where nodeGroup = '<guid>'

I'd expect that this will be a fairly small list, and quite possibly only a single guid.. If you see a large number of guid's reported, let me know, as something else may be wrong.

Note: once you clean up the bad guids, you will need to restart your browser session for the permissions to take effect.

If the above steps do not address the issue, then a sure fire way to resolve the issue is by completely resetting the admin permissions back to their default. The following query will reset all admin permissions:

delete from WD_NodeSecurity

After making this change to the database, perform an iisreset, and restart the browser.. Full administrator access will be restored for all users. It will then be necessary to reset the desired admin security permissions.. 

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Comments
dbeckner
By Level 10 Champion
Level 10 Champion

Hey @CharlesW - We've got a situation that started today where none of the admins can see the browse catalog, admin, dashboard, or my requests tabs. When i used this web services to check for bad guids it is showing every admin guid from the WD_NodeSecurity table. Im guessing something else is going on. I know that we could use the hammer approach and delete all the records from that table but i dont want to do that if theres another issue and this is  just the symptom.

 

Any thoughts?

dbeckner
By Level 10 Champion
Level 10 Champion

@CharlesW Found the issue. Service account got locked out causing database calls errors. 

Version history
Last update:
‎Jun 30, 2020 02:55 PM
Updated by: