kevin_philpot
Active participant

ServiceNow Integration with AppPortal Issue

Jump to solution

We are working to test using ServiceNow as the front-end for App Portal requests.   We have set up the initial integration via the documentation and have successfully imported the catalog items into ServiceNow.  

When we go to test submitting a request thru the ServiceNow service catalog we are able to find the catalog items, but when trying to submit a test request we do NOT see a spot on the form for the target device name and/or where to specify the install or uninstall action. 

Below are questions from our internal ServiceNow engineer, that we are trying to get assistance with:

  • After importing the software catalog items from Flexera and visiting the individual items to submit a request, we do not see any fields that the user can fill out. We examined the catalog items and it looks like there are no variables or variable sets linked to the catalog items. In order to see the device selection field in the form, we have to visit the catalog item definition and manually add the existing variable set "App Portal Variable Set". Is the Flexera import service supposed to automatically link the variable sets to the imported software catalog items or does that have to be done manually?
  • How does the integration handle software uninstall requests?

Thanks for your help.

0 Kudos
1 Solution

The REST API documentation does not really mention it,  but you would need to add the following to the request body for the submit order endpoint:

"request":1

(the default value is 0, which is install).. A Jim had mentioned you would have to figure out how to modify the workflow logic in ServiceNow. I hard-coded the above value in the submit order script and now my ServiceNow instance only submits uninstall requests :). I just wanted to show where this might be done.  I'm hesitant to get into anything involving the modification of the default workflow, but I did want to illustrate that it should be fairly straightforward.. The following screen capture illustrates:
ServiceNowSubmitOrderScript.png

View solution in original post

2 Replies
jdempsey
Moderator Moderator
Moderator

If the integration is configured and working correctly, then the variable set will be applied automatically to all App Broker catalog items.  It sounds like that isn't happening, so start by looking at the ServiceNowIntegration.log file on the App Broker server.  From there, look at incoming REST logs in ServiceNow.  This issue is frequently an issue with permissions for the integration account in ServiceNow.  A quick troubleshooting step is to give the integration account full Admin rights in ServiceNow and test the sync process.  If the variable set gets applied (only on new items, not updated items), then you can confirm it is a permissions issue and then review the permissions (or lack of permissions) that may be blocking that action from occurring (again, you can hopefully see what's going on in the incoming REST logs in ServiceNow).  If you can't figure it out from this information, then please submit a support case, and our Support team will be happy to assist you.

As for the install vs. uninstall, that is not currently a feature of our out-of-box integration.  This is configured only for installations.  However, if you are comfortable making modifications in ServiceNow, you could add your own variables to the App Portal Variable Set, or manually add an additional variable set, that asks install/uninstall and then applies that variable in the Submit Order step of the workflow.  This would also involve modifying the logic in the Submit Order activity to look at that variable and modify the REST call being made to reflect install or uninstall.

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".
0 Kudos

The REST API documentation does not really mention it,  but you would need to add the following to the request body for the submit order endpoint:

"request":1

(the default value is 0, which is install).. A Jim had mentioned you would have to figure out how to modify the workflow logic in ServiceNow. I hard-coded the above value in the submit order script and now my ServiceNow instance only submits uninstall requests :). I just wanted to show where this might be done.  I'm hesitant to get into anything involving the modification of the default workflow, but I did want to illustrate that it should be fairly straightforward.. The following screen capture illustrates:
ServiceNowSubmitOrderScript.png

View solution in original post