Workflow Manager Setup Requires IIS Virtual Roots Error

Workflow Manager Setup Requires IIS Virtual Roots Error

This article details an issue when installing AES/WFM 2016 or later on Windows 10 or Server 2016.

Symptoms

When trying to install AdminStudio Enterprise Server (AES) or Workflow Manager (WFM) 2016 or 2017 on Windows 10 or Server 2016 you will receive an error stating, "The following items are required to launch this step: This setup requires Internet Information Server for configuring IIS Virtual Roots. Please make sure that you have IIS installed."

Cause

This issue is caused by changes to the MajorVersion registry entry for IIS, and how the installer is detecting this.

Steps To Reproduce

  1. On Windows 10 or Server 2016, install IIS according to the Workflow Manager Installation Guide.
  2. Launch the Workflow Manager Installer
  3. Note the error "The following items are required to launch this step: This setup requires Internet Information Server for configuring IIS Virtual Roots. Please make sure that you have IIS installed."

 

Resolution

This issue will be addressed in a future release of AES/WFM, and is currently being tracked under issue number IOJ-1772951.

Workaround

To work around this issue please do the following:

  1. Open the registry editor. This could be done by hitting the start button and searching for regedit, or by pressing Win+R and typing regedit.exe into the run program.
  2. Locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\Parameters
  3. Locate the MajorVersion DWORD entry
  4. Set this value to 0x00000009 (9)
  5. Launch the AES/WFM installer
  6. As soon as you reach the welcome dialog you can set the MajorVersion back to: 0x0000000a (10)
  7. Complete the installation as normal
Labels (1)
Was this article helpful? Yes No
100% helpful (1/1)
Version history
Revision #:
2 of 2
Last update:
‎May 08, 2019 07:55 AM
Updated by: