cancel
Showing results for 
Search instead for 
Did you mean: 

Manually Enable Integration with All Versions of Visual Studio .NET

Manually Enable Integration with All Versions of Visual Studio .NET

Summary

This article provides information regarding how to manually enable integration with all versions of Visual Studio .NET.

Synopsis

This article discusses the manual steps necessary to enable integration between InstallShield and Visual Studio .NET so that InstallShield projects can be created and added to Visual Studio .NET Solutions.


Discussion

1. Use RegSvr32.exe to register IsDevEdt.dll, IsDevPkg.dll, and IsDevWiz.dll which are found in the System sub-directory of the main InstallShield installation directory location.
2. Locate devenv.exe corresponding to the version of Visual Studio.NET you are interested in. For example, InstallShield 2013 supports Visual Studio.NET 2012 and this is located in the following folder:
C:\Program Files\Microsoft Visual Studio 10\Common7\IDE
3. Run devenv.exe /setup in a command prompt (DOS) window.

NOTE: InstallShield Express users should substitute IsExpEdt.dll, IsExpPkg.dll, and IsExpWiz.dll in Step 1.

Related KB Articles

For an alternative approach to enabling Visual Studio .NET integration, see the Knowledge Base article Manually Enable Integration with All Versions of Visual Studio .NET and Enabling Microsoft Visual Studio .NET Integration and
Repair InstallShield Integration with Visual Studio

Additional Information

Only certain versions of Microsoft Visual Studio .NET are supported with specific versions of InstallShield products. For example:
  • Microsoft Visual Studio .NET 2017 is supported by InstallShield 2016 SP1 and later.
  • Microsoft Visual Studio .NET 2015 is supported by InstallShield 2015 and later.
  • Microsoft Visual Studio .NET 2013 is supported by InstallShield 2013 and later.
  • Microsoft Visual Studio .NET 2012 is supported by InstallShield 2012 Spring and later.
  • Microsoft Visual Studio .NET 2010 is supported by InstallShield 2011 and later.
  • Microsoft Visual Studio .NET 2008 is supported by InstallShield 2009 and later.
  • Microsoft Visual Studio .NET 2005 is supported by InstallShield 11.5 and later.
  • Microsoft Visual Studio .NET 2003 is supported by InstallShield X and later.
  • Microsoft Visual Studio .NET 2002 is supported by InstallShield Developer.

If your version is not listed above, please review the Release Notes for your particular release as this contains the most current information
Labels (1)