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Setup.exe Error 1152
Setup.exe Error 1152
Summary
Discussion and resolution for run time error 1152 for compressed executables.Symptoms
Error 1152 is only encountered at run time and is displayed in the following format:
Error extracting <FILENAME> to the temporary location.
Cause
When a compressed network image (single compressed setup.exe) is launched, the files compressed within it will be extracted to the TEMP folder and launched from that location. If one or more files cannot be extracted, then error 1152 occurs.
Resolution
A. Verify that the TEMP folder is writable.
The TEMP folder is the folder used by the system to place temporary files that can be deleted at a later time. Provide users with Write privileges to the TEMP folder. Follow the steps below to determine the TEMP folder for your system and the permissions set on the folder.
- To find the name of the default Temp directory, launch the DOS prompt on the machine, type 'Set T', and then hit the 'Enter' key. This will display the values of all the environment variables that have names that start with 'T', including TEMP.
- Open Windows Explorer. Using the directory name found in Step 1, locate the TEMP folder, right-click on it, and choose properties. Verify that the Read-Only check box is not checked.
- If you are running the installation on a Windows 2000 or Windows NT Operating System that is using a NTFS partition, verify that the user running the setup has permissions to write to this folder.
- Right-click the TEMP folder, and choose properties. Now select the Security tab. A list of users will be viewable within this tab. The permissions for each user will be viewable underneath. You can add additional users and change permissions if needed. Permissions should not be an issue if running on Windows 9X systems.
B. There is not enough disk space on the hard drive in which files are being extracted.
Clean the default TEMP folder and Free up as much disk space as possible on the drive that holds the TEMP folder.
C. One or more files have been corrupted. This may have occurred if the installation was downloaded.
- Re-download and rerun the installation.
- If the installation is being run from a network location, try running it locally.
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