This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
- Revenera Community
- :
- InstallShield
- :
- InstallShield Knowledge Base
- :
- Performing Offline Activation of InstallShield 2010 Fails to Activate the Product on Windows 7
Subscribe
- Mark as New
- Mark as Read
- Subscribe
- Printer Friendly Page
- Report Inappropriate Content
Performing Offline Activation of InstallShield 2010 Fails to Activate the Product on Windows 7
Performing Offline Activation of InstallShield 2010 Fails to Activate the Product on Windows 7
Summary
During Offline Activation of InstallShield 2010, after saving the License Request file and clicking the Next button, a dialog states that Activation has been successful. However, when InstallShield 2010 is launched, start-up fails with an error stating the product is not activated.Symptoms
During Offline Activation of InstallShield 2010, after saving the License Request file and clicking the Next button, a dialog states that Activation has been successful. However, when InstallShield 2010 is launched, start-up fails with an error stating the product is not activated.
Cause
When performing Offline Activation, after generating the request code, the product does not save its state as in offline activation state. Upon restart, no dialog appears to accept the response code. This leaves the InstallShield 2010 product inactivated, even though the activation process states it completed without error.Steps To Reproduce
Perform offline activation of InstallShield 2010 on a system running Windows 7.
Workaround
There are two options for working around this issue:I) Activate online
II) Activate offline following this procedure:
- Select the 'Proceed with Offline Activation' option
- Email Flexera Software the generated Request Code
- Wait for a return email containing the Response Code
- Download and uncompress the .zip file found in the attachments section of this Knowledge Base article
- Run the Offline.reg file by double clicking on the file from within Windows Explorer. This will place a key value in your registry.
- Reopen the InstallShield 2010 IDE
- When prompted for the response code, paste in the Response Code contained in the returned email.
Additional Information
This problem is being tracked internally by issue IOB-000058716, and a fix will be released with a later version of the product.Related KB Articles
Q209194
No ratings