Showing results for 
Show  only  | Search instead for 
Did you mean: 

Memory Access Violation When Building a Project Which Contains a Large Number of Files

Memory Access Violation When Building a Project Which Contains a Large Number of Files


InstallShield crashes with memory violation Exception ACCESS_VIOLATION (0xc0000005) when building a project which includes a large number of files.


InstallShield crashes at built-time when building an InstallScript project with a large number of files. The crash details show: Exception ACCESS_VIOLATION (0xc0000005)


The crash is due to a buffer overflow which occurs when building an InstallScript project which contains a large number of files. For example this can occur when building an InstallScript project that has more than 150,000 files included, or with a project that only has 60,000 files as well with longer file names.


This HotFix can be applied to all InstallShield 2018 Editions.

To apply the HotFix please perform the following:
  1. Download the HotFix '' from the Attachments section of this article.
  2. Make sure InstallShield 2018 is not running.
  3. Locate the InstallShield 2018 installation directory and open the system folder, by default this path is:
    1. 64-Bit Default Installation Location: C:\Program Files (x86)\InstallShield\2018\System
    2. 32-Bit Default Installation Location: C:\Program Files\InstallShield\2018\System
  4. Back up the following files by renaming them as noted below.
    1. Rename the file 'FrmWrkLib.dll' to 'FrmWrkLib_org.dll'
    2. Rename the file 'MediaBuild40.dll' to 'MediaBuild40_org.dll'
  5. Extract the contents of '', copy these files to the InstallShield system directory.

Additional Information

This issue is being tracked internally under Issue #IOJ-1861264.
Was this article helpful? Yes No
No ratings

This solution does not work for Installshield 2018. After updating these two files, Installshield IDE starts crashing on launch itself.

Tried with command line build and using automation interface to build the project without launching the Installshield IDE, it creates an empty image without any .cab file. Also does not generate any report file.

Please provide a fix ASAP. We have a release delivery deadline.

As per release note, this issue is fixed in IS 2018,,Services%20view%20for%20a%20website.&text=Set%20the%20Forms%20Authentication%20option%20to%20Yes%20to%20enable%20forms%20authentication.

You can also directly upgrade to Installshield 2018 R2, so that you need to install any hotfix,

If you have more files in your project ism file, then close Installshield IDE, and go below and

"C:\Program Files (x86)\InstallShield\2018\Support\0409" 

and check for settings.xml file and make a copy of it and keep one with settting_Org.xml and other one rename it to setttings.xml and open it and change below value to 20 or 50 or 100 or 200 

<VirtualMediaMemoryMaxSize default="10"/> 

Then save and close the xml file then relaunch installshield and try to build the project again and check it works or not.

Thanks for your reply. I am already using Installshield 2018 R2.

I will try your solution of updating the settings.xml file and let you know how it goes.



I tried setting <VirtualMediaMemoryMaxSize default="10"/> with values 100, 200 and 500 but it still fails. I am using Installshield 2018 R2. We have a release deadline.

Is there any other solution?

The detailed error shows up as:

Exception ACCESS_VIOLATION (0xc0000005)
at address 0x6f9c2b4a trying to read address 0xfffffff2.

File : C:\Program Files (x86)\InstallShield\2018\System\isdev.exe
Version :
Exception : c0000005
Address : 6f9c2b4a
Access Type : read
Access Address : fffffff2

Registers : EAX=fffffff2 CS=0023 EIP=6f9c2b4a EFLGS=00010283
: EBX=25666520 SS=002b ESP=0018e0c4 EBP=0018e0cc
: ECX=0cdcea00 DS=002b ESI=fffffff2 FS=0053
: EDX=ffff8155 ES=002b EDI=6fc5c734 GS=002b

Stack Trace : 6f9c7700 6f9d5452 6f9d6416 6f9d7cd2
: 6f9d3413 6f9d4d95 6f9c48bc 6fa27adc
: 6fa07a49 0eb385e6 0eb37b84 0eb37bc8
: 0eb2771a 0eb2aa7f 0eb13c44 0eb0b724
: 0eb06a7a 0eb069f1 0eb071d8 0e778587
: 0e60b184 0e60c7c7 07756db8 07754647
: 07725357 07739654 0774e9b3 0e09e8e6
: 0e0a305f 72f891f7 731d92bc 72f58026


Thanks & Regards


<VirtualMediaMemoryMaxSize default="100"/>

<VirtualMediaMemoryMaxSize default="200"/>

<VirtualMediaMemoryMaxSize default="500"/>

All fail with the same error.

What is the number of files in your project?

Could you please share the error screenshot.


Our Installation has more than 350,000 files. 

It failed to upload the screenshot. I have uploaded a video containing the screenshot of the error. 

Expecting a quick response.

Thanks & Regards

Precisely, Our Installer has around 400,000 files. It may even go up further soon.

Version history
Last update:
‎Apr 14, 2018 02:08 AM
Updated by: