cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Japanese Command Line Build Output Does Not Include Japanese Characters

Japanese Command Line Build Output Does Not Include Japanese Characters

Summary

The output of the Japanese edition of InstallShield 2014 command line builder (ISCmdBld.exe) does not display Japanese characters correctly.

Symptoms

When building a project using the Japanese edition of InstallShield 2014 command line builder (IsCmdBld.exe) on a Japanese operating system, the Japanese characters in the build output are displayed as ??? rather than the correct Japanese characters.

Cause

This issue is caused by a bug introduced in the Japanese edition of InstallShield 2014.

Resolution

The issue is currently being tracked by work order IOJ-1661825 and will be addressed in a future version of InstallShield

Workaround

In order to resolve the issue in the Japanese edition of InstallShield 2014 Service Pack 1 apply the HotFix attached to this article by following these steps:
  1. Ensure the InstallShield 2014 Service Pack 1 IDE is not running.
  2. Rename the file
C:\Program Files (x86)\InstallShield\2014\System\IsCmdBld.exe
to:

C:\Program Files (x86)\InstallShield\2014\System\ORIG_IsCmdBld.exe
3. Download the attached .zip file.
4. Extract the updated IsCmdBld.exe from the attached .zip file to the InstallShield System folder.

After applying this HotFix the build output will display the correct Japanese characters.

Related Documents

Verbosely Log a Command Line Build

Related KB Articles


Was this article helpful? Yes No
No ratings
Version history
Revision #:
1 of 1
Last update:
‎Jul 02, 2018 10:00 PM
Updated by: