Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Web Deploy package type in Suite project


I am trying to deploy a web package in a suite installer project.

Here is what I am getting in the log:

9-30-2019[04:37:45 PM]: Engine: property 'ISInstallStatus' value now 'Installing package AutoVu.Plugins.SBIntegration'
9-30-2019[04:37:45 PM]: Engine: property 'ISParcelStatus' value now 'ID_STRING5'
9-30-2019[04:37:45 PM]: Webdeploy package target: C:\Users\ckari\AppData\Local\Downloaded Installations\AutoVu.Plugins.SBIntegration\
9-30-2019[04:37:45 PM]: Passing webdeploy command line:
9-30-2019[04:37:45 PM]: Engine: request for proxy handler, 0, 0
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Attempting to load through CLR 4 APIs...
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Getting meta host...
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Enumerating available runtimes...
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Highest available runtime: v4.0.30319
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Trying to use highest runtime...
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Using highest version runtime...
9-30-2019[04:37:47 PM]: (WebDeploy Parcel): Managed code threw an unhandled exception.
9-30-2019[04:37:47 PM]: Parcel operation return status: 80070643

Did anyone run into a similar issue and found what to do?

Thanks for any help, it would be much appreciated



Labels (1)
0 Kudos
(5) Replies

Hi @ckari_genetec ,

Looks like the problem is related to the manged code run-time,  Can you try by specifying the CLR version required for your managed code.

Refer the below link for "IS_CLR_VERSION" property to specify the runtime:


One more related link, but it is not related to suite project:


0 Kudos
Level 3

Did you ever find out what was going on here? I'm experiencing the same error and have not gotten past it yet. The CLR version is correct.
0 Kudos

No, I just abandoned the idea to use the suite to deploy. Using WebDeploy tool instead.

Good luck!

Claire 🙂

0 Kudos

Thanks for responding. I've had a support ticket in on this for a week now but no response yet. Thanks again!
0 Kudos

I worked my way through this not -very-helpful error and in case anyone is experiencing the same situation this is what I found. In my case this was Windows Server 2016:

What I found was that there are items required to be installed on the target machine before the web deploy install is run or you can get nondescript errors during the install. Having the machine setup just for local web deploy package imports is not sufficient. This is because the web deploy package in IS uses the remote deployment capabilities of IIS. Those capabilities are not required for doing manual local web deploy zip file imports into IIS. This is what I found to be required for it to work, and to receive meaningful feedback in the install log:

Obviously the machine must have IIS installed. Not as obvious is that the Web Management Service option in IIS must be installed as well. Then MS Web Deploy must be installed. It must be installed after the Web Management Service to get the options available that are needed. MS Web Deploy must include the Remote Agent Service, since this is used by InstallShield's web deploy project. Before the web deploy package will be successful in the IS installer, both the Web Management and Web Deployment Agent Services must be installed and running on the machine.

I hope this can help someone out.
0 Kudos