KGalloway
Level 4

Visual Studio 2017 does not recognize InstallShield 2018 after Upgrade to 2018 R2

After updating to 2018 R2, VS2017 marked my setup projects as "incompatible" and when clicked claims that "The application is not installed."

Any ideas to fix it? Anyone else have the problem.
Labels (1)
0 Kudos
15 Replies
rguggisberg
Level 13

Are you using .Targets files? They need to be updated. Typically in
C:\Program Files (x86)\MSBuild\InstallShield\201x
0 Kudos
KGalloway
Level 4

Thanks for getting back on the post. There are 2 files there InstallShield.targets and InstallShield.Tasks.dll. How do I update them?
0 Kudos
rguggisberg
Level 13

Well it looks like that is probably ok then.
Open InstallShield.targets with notepad and search for
201
You should have a line that ends with
C:\Program Files (x86)\InstallShield\2018\System
0 Kudos
rguggisberg
Level 13

Notes:
1. InstallShield versions can be installed side-by-side.
2. The last version of InstallShield that is installed or repaired on a system is the one that is used for Visual Studio integration.
0 Kudos
KGalloway
Level 4


C:\Program Files (x86)\InstallShield\2018\System


InstallShield 2018 R2 is the way that the current version in listed in Programs and Features and a file search finds only the internet files for these posts.

Any help will always be appreciated, but have you updated to 2018 R2 yet? Considering my experience you might not want to, but thanks for the input so far.
0 Kudos
KGalloway
Level 4

If I select InstallShield 2018 R2 in Programs and Features the update program will allow for neither repairing or removing at the moment.
0 Kudos
rguggisberg
Level 13

Yes I upgraded to 2018 R2 from 2018. It was painless.
What version did you upgrade from?
Presumably you are on your development machine and not a Stand Alone Build machine ???
0 Kudos
KGalloway
Level 4

On my development machine
0 Kudos
Jenifer
Flexera Alumni

KGalloway1 wrote:

C:\Program Files (x86)\InstallShield\2018\System


InstallShield 2018 R2 is the way that the current version in listed in Programs and Features and a file search finds only the internet files for these posts.

Any help will always be appreciated, but have you updated to 2018 R2 yet? Considering my experience you might not want to, but thanks for the input so far.


Hi

The error according to visual studio forums,it is specific to associated software or its associated components missing on the system.

You could try few steps to get exact cause for this issue:

1.Have you tried launching installshield once at-least to see the launch behavior of IDE?

2.Had Visual-Studio been launched as Administrator?

3.Rare but may be cause,Visual Studio 2017 update could have also caused .

If you had tried all these already,you can try repairing/uninstalling installshield setup with /debuglog option.-http://helpnet.flexerasoftware.com/installshield19helplib/helplibrary/IHelpSetup_EXECmdLine.htm -debuglog
If possible attach log here to get to know cause in detail.

Thanks,
Jenifer
0 Kudos
KGalloway
Level 4

1.Have you tried launching InstallShield once at-least to see the launch behavior of IDE? Yes
2.Had Visual-Studio been launched as Administrator? Yes
3.Rare but may be cause,Visual Studio 2017 update could have also caused . VS2017 is up-to-date
0 Kudos
Jenifer
Flexera Alumni

KGalloway1 wrote:
1.Have you tried launching InstallShield once at-least to see the launch behavior of IDE? Yes
2.Had Visual-Studio been launched as Administrator? Yes
3.Rare but may be cause,Visual Studio 2017 update could have also caused . VS2017 is up-to-date


So what was the outcome of those?

Were you able to launch installshield IDE?

Please try running Installshield-setup with debuglog option,where you can choose modify/uninstall .Try attaching log here


Thanks,
Jenifer
0 Kudos
KGalloway
Level 4

So what was the outcome of those?
1.Have you tried launching InstallShield once at-least to see the launch behavior of IDE? Yes
2.Had Visual-Studio been launched as Administrator? Yes
3.Rare but may be cause,Visual Studio 2017 update could have also caused . VS2017 is up-to-date
10-05-2018, 01:20 PM

Were you able to launch InstallShield IDE? Yes

Please try running InstallShield-setup with debuglog option,where you can choose modify/uninstall .Try attaching log here
I do not have access to the setup for InstallShield. I am going to get the software reinstalled by the SysAdmin group.

I will let you know if that resolves the issues.
0 Kudos
KGalloway
Level 4

I did an uninstall which took some manual closing of items related to InstallShield, installed from InstallShield2018SP1ProfessionalComp and then checked the integration with VS2017 which worked fine. I then installed from InstallShield2018R2ProfessionalComp and the system is now fully 2018 R2, activated and integrated with VS2017.

Jennifer,
Thanks for your earlier assistance however I was unable to run either InstallShield2018SP1ProfessionalComp or InstallShield2018R2ProfessionalComp with command line parameters so keep that in mind for future assistance to others.
0 Kudos
Jenifer
Flexera Alumni

KGalloway1 wrote:
I did an uninstall which took some manual closing of items related to InstallShield, installed from InstallShield2018SP1ProfessionalComp and then checked the integration with VS2017 which worked fine. I then installed from InstallShield2018R2ProfessionalComp and the system is now fully 2018 R2, activated and integrated with VS2017.

Jennifer,
Thanks for your earlier assistance however I was unable to run either InstallShield2018SP1ProfessionalComp or InstallShield2018R2ProfessionalComp with command line parameters so keep that in mind for future assistance to others.


Though you could see VS2017 integration working after uninstalling IS-SP1\reinstalling IS-2018-R2, i would have given more insights about the issue with log files.If you could uninstall\install ,i hope you have access to 2018SP1 or 2018 R2 setup launcher.Here is how can you get log file for future reference :

-Execute InstallShield2018R2ProfessionalComp.exe /debuglog"C:\PathToLog\setupexe.log" from cmd.exe

From log file,you can trace for exact error and post.So that you may get proper replies from forums 🙂

Thanks,
Jenifer
0 Kudos
KGalloway
Level 4

Jennifer,
Thanks again!
0 Kudos