cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sureshkottakki
Level 6

Upgrade issue

Hi,
I have created a Installscript MSI project with Service(exe) in it and installed with version 1.00.0000. Now we changes the components versions and installer version to 1.00.0002 and installed, Now it is asking for upgrade, so we upgraded, but after upgrade it is asking for System Reboot . We don't want this reboot after the upgrade.

Thanks in advance
Labels (1)
0 Kudos
10 Replies
rrinblue22
Level 9

Check this which may help you avoid the restart prompt.
0 Kudos
sureshkottakki
Level 6

Hi ,
I tried with all the three options
1)0
2)Disable
3)DisableShutdown
,but still that Reboot dialog is coming
0 Kudos
Not applicable

Make sure your service is shutting down before the upgrade starts if you're replacing the service executable file. It can't replace that file if the service has failed to shutdown for some reason and would require a reboot in that case.
0 Kudos
sureshkottakki
Level 6

Hi Hysteresis,
While upgrade , I am calling a dll function which will stop the service, just before the Welcome dialog while upgradation, still it is showing the Reboot dialog
0 Kudos
rrinblue22
Level 9

Few things here:

Can you sequence your action which stops the service before FileCost standard action and see if that works?

along with, you can try to suppress the reboot prompts in certain time by setting the REBOOT property.

If none of these work, you may also check in specific for the file/folder which is being locked in the registry which is prompting for system reboot.
Based on that you can proceed to free the file/folder being accessed.
0 Kudos
sureshkottakki
Level 6

Its a bit urgent , can u guys help me out in this one
0 Kudos
sureshkottakki
Level 6

Hi rrinblue22,
I tried with all the three values of REBOOT property, but still getting that dialog. Later I checked in registry HKLM\SYSTEM\CurrentControlSet\Control\Session Manager , in this inside the PendingFileRenameOperations, the value is
\??\C:\Users\ADMINI~1\AppData\Local\Temp\{CB1A9911-8637-4DF5-B4C0-66E4321FC6AC}\setup.exe.
The screen shot is
So what shall I do to overcome this .
Thanks in Advance
0 Kudos
Not applicable

Have you tried generating a full verbose MSI log of the upgrade sequence. That might give you further clues.
0 Kudos
rrinblue22
Level 9

As Hysteresis suggested, see if something is weird in the verbose install/upgrade log.

so, what happens if you happen to stop the services in question manually (just for a test) and then perform an upgrade.

What I'm trying to figure out is, it could be something else if not the service alone.
0 Kudos
sureshkottakki
Level 6

Hi rrinblue22/Hysteresis,

I tried out to call the dll function which will stop the service in ONBEGIN function, now it is working fine , the Reboot dialog is not coming , Thanks for your help and your valuable time.
0 Kudos