cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

Unable to install Type 1 (Postscript) fonts on Windows 10 build 1909

I have built a basic msi project to install True Type and Postscript fonts for a customer. The TT fonts install perfectly and while the Postscript fonts are in the right location and are in the registry they do not appear in the Fonts applet and the CharMap utility. If I double click a Postscript font file *.pfm, and choose Install for all users, a dialog is displayed indicating the font is already installed. After completing the install the font appears in both the Fonts applet and the CharMap utility.

To install the fonts I am using these settings:

Template Summary x64;1033

64 bit component = yes (required to get the associated registry settings into 'HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Type 1 Installer' rather than 'HKLM\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Type 1 Installer'.

Installscript call to RegisterFontResource  which returns ISERR_SUCCESS

I am at a loss as to what else to do. It is obvious that something has to happen, although this does not appear to be in the registry as there are no differences between the msi install and double clicking a *pfm file. Previously the Postscript font install was achieved using the shell CopyHere method, however this now installs the font in the user font location, which is not recognized by the application that requires these fonts.

Any help would be appreciated.

Jon

Labels (1)
0 Kudos
2 Replies
Flexera
Flexera

Re: Unable to install Type 1 (Postscript) fonts on Windows 10 build 1909

Hi @jonbee ,

 

  • Though the problem seem to be specific to font installation,i have few other points to add on
  • On setting 64-bit component to yes,you need not to worry registry/file redirection(with/without SysWOW64).InstallShield will do the job for you
  • How about doing font installation via Component Wizard.This can be done via 2 ways
    • On Choosing best practices option(First combo choice) and choose [ FontsFolder].Select the files to be installed
    • Opt for second choice,and select the checkbox item "i want to add fonts not installed on system"

I would prefer first method.Let me know if it works!!

 

Thanks,

Jenifer

0 Kudos
Highlighted
Flexera beginner

Re: Unable to install Type 1 (Postscript) fonts on Windows 10 build 1909

Thanks for responding Jenifer! 😊

Firstly I have got a solution working with a dll that implements a Win32 API call to install the Type 1 fonts, that I call from a custom action.

In answer to your suggestions:

  • I'm fairly certain that, without X64, set the package populated the HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Type 1 Installer\Type 1 Fonts key instead of the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Type 1 Installer\Type 1 Fonts, even though the latter was set in the Installshield project. Given the package is now working for me, and I have spent way to much (unbillable) time on this, I am not going to go back and verify one way or the other.
  • The Component Wizard fonts option is limited to *.fon or *.ttf files only. I have used this for the installation of the customers custom True Type fonts.

Jon

0 Kudos