cancel
Showing results for 
Search instead for 
Did you mean: 
jophyjob
Pilgrim

Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello All ,
When we create setup from Local build VS 2012 the setup created have all dll's ( we can see depended dll in install folder ) , but when we build setup from MSBuild some dll is missing . We are creating setup for WPF application , and when we check closely we see that dll's missing is that not have direct call from the code ( like Theme dll ) . We add project and Set fine dependence auto in installshield , our project are in active development so we cannot dll one by one manually .

Command used in MSBuild is :

D:\Projects\installShieldThemeIssue>C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe /p:SkipInvalidConfigurations=true /p:Configuration="Release" /p:Platform="Any CPU"
/property:InstallShieldpath="C:\Program Files (x86)\InstallShield\2013LE\System" /filelogger

We are using Vs2012 , install Shield 2013 come with vs , Wpf project 4.5 .


with regards
jophy
0 Kudos
8 Replies
Flexera chiranjeevi
Flexera

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello,

Does this behavior exist for all other projects or only in this project specifically?

Could you please kindly try readd all the files which were included in the project and check if it shows the same behavior ?

Thanks,
Chiranjeevi
0 Kudos
Highlighted
jophyjob
Pilgrim

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello chiranjeevi,
we see this error first in our main application , then i tried in sample application ( "log provided with this") both have the same issue . When we look in the dependence list it have all the dll ( including missing dll's ) . But when build and install some dll not installed on client machine .

with regards
jophy
0 Kudos
Flexera chiranjeevi
Flexera

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello jophy,

Could you please kindly provide me the reproduciable sample project to investigate the issue further?

Regards,
Chiranjeevi
0 Kudos
jcoone
Pilgrim

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

This seems very similiar to the issue that I am experiencing.

I have a thread posted here: http://community.flexerasoftware.com/showthread.php?207387-TFS-Build-MSBuild-not-including-scanned-d...

I have also posted on the Visual Studio forums here: http://social.msdn.microsoft.com/Forums/en-US/tfsbuild/thread/11b700d9-9d9b-4977-993c-af44ce5ed91d/


My issue is caused by referencing any 3rd party or redistributable DLLs that are registered in the GAC, even if the file reference is pointed to a copy of the DLL other than the one registered in the GAC so long as there is a copy in the GAC it does not get included into the MSI package if the installer is built from the MSBuild command line or the TFS build process.
0 Kudos
jcoone
Pilgrim

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Follow up:

If I build it in Visual Studio (on my local machine or on the build server) The MSI generated has all of the necessary DLLs for the application to run.

If I build using the MSBuild command line (local or on server) or if I run the build through the TFS Build Process the MSI generated does not have the 3rd party DLLs that are referenced by the main project. Only referenced DLLs seem to be affected by this issue. Also, we have tried doing direct references within a source controlled file references folder instead of the GAC registered DLLs, but the behavior is the same even when the ones in the GAC have been uninstalled and direct file references from the main project are used.

in the ISPROJ file I am using the .Primary_output from the main executable project to include the files in the installer, and everything works fine when building within Visual Studio 2012 but not when building the solution from the MSBuild command line or in the TFS build process. The third part DLLs are present in the TFS build drop location, but are not being included into the MSI package.
0 Kudos
Flexera chiranjeevi
Flexera

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello,

Currently, we are working on this issue with our engineering team, a reproducible sample will help us to understand the issue better.

Please kindly provide us the required sample project to investigate the issue further.

Regards,
Chiranjeevi
0 Kudos
jophyjob
Pilgrim

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello ,
Sorry for late replay . I attaching a sample WPF application with issue , it using sample theme in application and The theme dll not coming in MSBUILD build but it will come in VS build

with regards ,
jophy
0 Kudos
Flexera chiranjeevi
Flexera

Re: Some dll is missing in Installshield setup from TFS build (local or MSBuild ) ?

Hello Jophy,

Thank you for the sample project. we'll get back to you with further updates on this issue soon.

Regards,
Chiranjeevi
0 Kudos