Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Setup Hangs indefinately on Registering DLL

After checking "self register" on a com dll in our application setup always hangs when trying to register this dll on 64-bit Windows 2008 systems (haven't yet tried on 2003, but 2008 is our main target platform). On 32-bit systems the installation succeeds.

-The component housing the 64-bit version of the dll is marked as 64-bit

- Related running processes at that time running under SYSTEM:

  • msiexec.exe *32
    "Windows(R) installer"

  • msiexec.exe
    "Windows(R) installer"

  • wac32E4.tmp
    "InstallShield (R) 64-bit Setup Engine"

- Related running processes at that time running under logged in user:

  • msiexec.exe *32
    "Windows(R) installer"

  • setup.exe *32
    "Setup Launcher"

  • ISBEW64.exe
    "InstallShield (R) 64-bit Setup Engine"

- Killing msiexec.exe *32 (SYSTEM) makes the setup resume (as described in another thread regarding 64bit installations hanging)

Here is a snippet of the verbose log file just before the hang (at 11:53:35) and continuing after I kill the msiexec.exe *32 process (at 12:01:06). Note the time stamp that is from before the hang, but written after it resumes.

[CODE]MSI (s) (8C:84) [11:53:34:159]: Executing op: RegOpenKey(,Key=Component Categories,,BinaryType=0,,)
MSI (s) (8C:84) [11:53:34:565]: Executing op: RegCreateKey()
MSI (s) (8C:84) [11:53:34:596]: Executing op: RegOpenKey(,Key=Component Categories\{40FC6ED3-2438-11CF-A3DB-080036F12502},,BinaryType=0,,)
MSI (s) (8C:84) [11:53:34:596]: Executing op: RegAddValue(Name=409,Value=Embeddable Objects,Attributes=2)
MSI (s) (8C:84) [11:53:34:612]: Executing op: RegOpenKey(,Key=Component Categories\{40FC6ED4-2438-11CF-A3DB-080036F12502},,BinaryType=0,,)
MSI (s) (8C:84) [11:53:34:612]: Executing op: RegAddValue(Name=409,Value=Controls,Attributes=2)
MSI (s) (8C:84) [11:53:34:643]: Executing op: RegOpenKey(,Key=Component Categories\{40FC6ED5-2438-11CF-A3DB-080036F12502},,BinaryType=0,,)
MSI (s) (8C:84) [11:53:34:643]: Executing op: RegAddValue(Name=409,Value=Automation Objects,Attributes=2)
MSI (s) (8C:84) [11:53:34:659]: Executing op: RegOpenKey(,Key=Component Categories\{40FC6ED8-2438-11CF-A3DB-080036F12502},,BinaryType=0,,)
MSI (s) (8C:84) [11:53:34:659]: Executing op: RegAddValue(Name=409,Value=Document Objects,Attributes=2)
MSI (s) (8C:84) [11:53:34:675]: Executing op: RegOpenKey(,Key=Component Categories\{40FC6ED9-2438-11CF-A3DB-080036F12502},,BinaryType=0,,)
MSI (s) (8C:84) [11:53:34:675]: Executing op: RegAddValue(Name=409,Value=_Printable Objects,Attributes=2)
MSI (s) (8C:84) [11:53:34:690]: Executing op: ActionStart(Name=ISSelfRegisterFiles,,)
MSI (s) (8C:84) [11:53:34:737]: Executing op: CustomActionSchedule(Action=ISSelfRegisterFiles,ActionType=3073,Source=BinaryData,Target=ISSelfRegisterFiles,CustomActionData=C:\Users\ADMINI~1\AppData\Local\Temp\~4A22.tmp)
MSI (s) (8C:C0) [11:53:34:753]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI791A.tmp, Entrypoint: ISSelfRegisterFiles
InstallShield 11:53:34: Initializing Property Bag...
InstallShield 11:53:34: Getting file count from property bag
InstallShield 11:53:34: File Count : 1
InstallShield 11:53:34: Sorting Based On Order...
InstallShield 11:53:35: ISBEW64.exe is successfully loaded for 64-bit registration
MSI (s) (8C:84) [12:01:06:690]: Executing op: ActionStart(Name=RegisterProduct,Description=Registering product,Template=[1])
InstallShield 11:53:35: Registering file C:\Program Files\MyInstallDir\ComToRegister.dll (64-bit)
MSI (s) (8C:84) [12:01:06:690]: Executing op: ChangeMedia(MediaVolumeLabel=DISK1,MediaPrompt=Please insert the disk: 1,,BytesPerTick=0,CopierType=2,ModuleFileName=C:\Windows\Installer\13b3a403.msi,,,,,IsFirstPhysicalMedia=1)
MSI (s) (8C:84) [12:01:06:690]: Executing op: DatabaseCopy(DatabasePath=C:\Windows\Installer\13b3a403.msi,ProductCode={MyProductCode},,,)
MSI (s) (8C:84) [12:01:06:690]: Note: 1: 1402 2: UNKNOWN\Products\MyProductCode\InstallProperties 3: 2
MSI (s) (8C:84) [12:01:06:706]: File will have security applied from OpCode.[/CODE]

Please could someone at InstallShield/Flexera look at this.
Labels (1)
0 Kudos
(2) Replies
Level 4

Some things I've tried:

0 Kudos
Level 4

This problem can be reproduced on other Win2k8 64 bit machine?
Did you try using regsvr32 or regasm to register the dll in console window?
0 Kudos