cancel
Showing results for 
Search instead for 
Did you mean: 
DrewMann
Pilgrim

Setting Registry Permissions causes install to fail

I edited by registry settings to allow full access for specific account. I recompiled my BasicMSI project and now the install fails with message cannot find [machine\company\program].

It fails for each of the registries i create and set permissions on. If i remove the permission settings all is well again. This is on 64bit machine install. Is this a bug or is there another way to set registry permissions?

Thanks
Drew
Labels (1)
0 Kudos
4 Replies
DrewMann
Pilgrim

UPdate on error message.

The error message recieved when i run MSI in full UI mode is

error 27555. Error attempting to apply permissions to object 'MACHINE\CompanyName\AppName'. System error: the system cannot find the file specified. (2)
0 Kudos
joshstechnij
Pilgrim

Re: Setting Registry Permissions causes install to fail

Please see this thread.
0 Kudos
DrewMann
Pilgrim

Thank you

Thank you for the follow up. In meantime I have managed to set registries using .NET 4 in my setup utility (exe) which I launch during install. Even then that was difficult since installer is running 32bit so appreciate the problems.

Cheers

Drew
0 Kudos
Mrunmayee
Pilgrim

ERRROR - ApplyPermissionsItems

In Installshield 2012 Spring also I'm getting below error while trying to set registry permission.

InstallShield 3:29:13: Error returned from ApplyPermissionsItems: 0x00000643

Any help would be appreciated.
0 Kudos