Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Serial Number Not Registered error - but it is!


So we recently purchased InstallShield 2012 Spring at work... I installed it on my machine, and created a new *.ism file with it... when I open the file, I get prompted by an "InstallShield Product Activation" window, asking me to "enter serial number." So... I put in the serial number, click Activate... this pops up "Serial Number Not Registered" with error 20661. So I clicked on "Register my productd online" .... put in the serial number... clicked Add... and it said that registration was complete. 3 days later... still getting the SAME error when I try to Activate.

After that, I went to the "Product and License Center" on the website, went to "Entitlement History," View license, and generated a license there, downloaded the utility to find my MAC address, and copy/pasted my MAC address into the Host ID thing... looked like everything went fine. The license looks like it's in place.

So I go to open my ism file... SAME problem. Still prompted for "Activate" and when I click on Activate and input my serial number, I still get the 20661 error.

Not only that, which is frustrating enough - but when I actually build a setup file with my current $2000 "Evaluation Version" the setup files don't even work. They claim to work for "5 days from the time the setup file was built" but as far as I can tell, the 5 days is actually calculated from the time that InstallShield is installed, not from when the setup is built. So basically I'm dead in the water right now. I'm about a day away from moving everything over to Visual Studio 2010 installer - I really need these setup files to work pretty much ASAP and it's already been half a week.

How do I get this $2000 product to activate. Anyone have the same issue?
Labels (1)
0 Kudos
(1) Reply
Level 3

I just had the exact same problem, but for the InstallShield 2015 Limited Edition. I registered twice (in case the first time was a fluke), but both of my provided serial numbers fail to work:

0 Kudos