thomas_leclaire
Level 2

Problems writing registry entries

Hello,

I’m using the InstallShield Limited Edition in Visual Studio 2012 and trying to create a registry entry on the destination System.
A look in the log file states that it has made the registry entry but when I open regedit, I can’t see it.

Am I doing something wrong, or is this a known issue…?
0 Kudos
9 Replies
Lenwin
Level 10

Could you kindly let us know the registry entries that you have created in the InstallShield Limited Edition project.
0 Kudos
thomas_leclaire
Level 2

See attached screenshot.
0 Kudos
Lenwin
Level 10

Could you look for the registry entries under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node.
0 Kudos
dhofferber
Level 5

I was disappointed to see this thread stop because I'm having the same problem. I’ve checked both the main Software and Wow6432Node with no luck. Any other ideas? :confused:
0 Kudos
Christopher_Pai
Level 16

Have you logged the installer and reviewed it?
0 Kudos
dhofferber
Level 5

Just did thanks. It appears that it doesn't have permission to write to the registry. How can I elevate permissions just for the installation?
0 Kudos
Christopher_Pai
Level 16

It should have been automatic (project defaults). Hard to say without looking at your solution.
0 Kudos
dhofferber
Level 5

You say that the permission should be granted by default. We don't seem to be able to get our installation to work without being an admin. I just started another post about this. Can you give me some guidance on how to elevate privileges during install? Thanks.
0 Kudos
SwethaRao
Level 7

Hello,

May be you have already tried this, if not, please right click on the setup.exe and select "run as administrator" and check if that helps.

Regards,
Swetha
0 Kudos