cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Problem including .NET Framework 4.5 into Project

I am currently having trouble adding the "Microsoft .NET Framework 4.5 Full" to a project. The project is an existing project that we have been using for awhile, and need to upgrade the framework. I have gone under the Redistributables tab, and checked the framework. I made sure that it was downloaded as well.

The project appears to build fine, but when I try to install the project I get a message that "The files for installation requirement Microsoft .NET Framework 4.5 Full could not be found. This is probably due to a failed, or canceled download”. I have tried setting it to both Copy from Source, and Extract from Setup, neither of which changes the message. When I look at the size of the files in the executable it does not look like anything is being included as well.

I have tried everything I could think of to get this into the install, including re-downloading in case there was an error, and various other combinations of settings. I am currently using Install shield 2013- Professional Edition, Version 20.

Had anyone had this problem, or know what I need to do in order to get the .NET installer included with the setup?
Labels (1)
0 Kudos
1 Reply
Highlighted
Flexera beginner

Re: Problem including .NET Framework 4.5 into Project

First, scan the build log and see if there are any warnings about the redistributable. Sometimes, InstallShield will produce the build seemingly without error. But, if you manually scan the build log, you may see some issues.

Next, make sure that the files referenced by the prerequisite actually exist on your computer:
On the Redistributables tab, right-click on "Microsoft .NET Framework 4.5 Full" and choose "Edit Prerequisite"
Go to the "Files to Include" tab in the Prerequisite Editor
Look at the File Name and Path to Local File. Verify that this path and files actually exist on your computer.

Also, check the Conditions tab and make sure that your release is set to use an OS actually supported by this prerequisite. (For example, .NET 4.5 full does not support Windows XP).

Hopefully this will at least lead you to the actual problem.
0 Kudos