Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 6

Previous version not removed from 'Uninstall or Change programs' after Major Upgrade

Starting this new thread since in the other thread I had posted on this subject got confusing due to my change in observations and having more details than wa necessary.

Kindly help with below please, I have spent too much time, trying to read up, google search based suggestions, etc. without any luck.

I have an InstallShield MSI script project.
We had released version 11.1.1200

Now we have version 11.2.1100 and I made changes to mark it as Major Upgrade.

After installing 11.2.1100, I still see entry for version 11.1.1200 in 'Uninstall or Change programs' , formerly known as 'Add/Remove Programs' in Control Panel.
So two entries showing up.

I changed product code and product version.
I created a Major upgrade item.

In the Commons tab, I have:
Selected second radio button 'Products having another Upgrade Code' and have the product upgrade code.(I also tried to select the first radio button 'Product sharing my Upgrade Code but no luck)
Selected to replace any earlier version. ( I also tried specifying a version range, but no luck)

In the Advanced tab I have:
I have the correct upgrade code
Minimum version is blank
Include minimum version set to Yes
Maximum Version set to ***ALL_VERSIONS*** (I also tried setting this to the current version but no luck)
Language left blank
Exclude Specified Languages set to No
Detect Only set to No
Detect Property set to ISACTIONPROP1 by default
Only Remove Specified Features set to blank
Continue on Failure set to No
Migrate Feature States set to yes.

I also tried below suggestion from the other thread without any luck:
Add a major upgrade item with the settings:
Products Sharing my Upgrade code
Within a specific version
Check the check box for Inclusive versions and enter your lowest ever version in the left box. Leave the right one blank.
Labels (1)
0 Kudos
1 Reply
Level 6

appreciate if anyone can help out. I have spent much time to resolve this but not getting anywhere.
0 Kudos