cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Occasional contributor

Prerequisites for .NET Framework 4.7.2 and higher

Hi there,

I hope someone can help me find a solution to a dilemma. Given that there have been several Windows 10 updates, different versions of Windows 10 now only support .NET Framework 4.8. I have applications that target the .NET Framework 4.7.2, but are also supported by .NET Framework 4.8. 

InstallShield 2019 allows you to select .NET Framework 4.7.2 as the prerequisite. Now, is there a way for InstallShield to set the prerequisite for .NET Framework 4.7.2 and higher versions? For example, if the .NET Framework is greater than or equal to .NET Framework 4.7.2, then let the install continue with installation.

The reason I ask is that my installers will halt for versions of Windows 10 1903 and higher because the installers cannot install .NET Framework 4.7.2 on those higher versions of Windows 10 (only .NET Framework 4.8 is supported). You could argue that I can remove the prerequisite of .NET Framework 4.7.2 (since .NET Framework 4.8 will still support my application), but I do not want to do that because lesser versions of Windows 10 that do support .NET Framework 4.7.2 might not have it installed.

Having said that, how can I approach this? I hope that this is not confusing and that someone might be able to help.

Thanks.

Labels (1)
0 Kudos
1 Reply
Highlighted
Flexera
Flexera

Re: Prerequisites for .NET Framework 4.7.2 and higher

Hi @standardsdesign ,

 

  • I dont think so it can be achieved by having single exe it is of either 4.8 or 4.7.2.Since one or other will fail in either higher versions or lower versions.
  • This could be achieved if Microsoft itself coming with Unique .NET framework installer that can be installed based on Windows 10 version condition
  • I could think of a solution having 4.7.2 exe base for lower versions and 4.8 base for any higher versions.(If you want to have 4.9 ot 5.0 later as base,this would still not fit into the requirement)
  • My suggestion would be create a Suite with two exe packages with detection condition as Windows 1903(for 4.8) and whichever lower version for 4.7.2
  • You can add Suite setup as pre-requisite with registry conditions being added

Thanks,

Jenifer

0 Kudos