Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Prerequisite showing on OS that was not specified

I have a Basic MSI Project that has several prereqs. I set the launch conditions for the MSI to be Win Vista SP2, Win 7 SP1, Win 8+ and their corresponding Server OSs. Now, when running the installer on Win XP, the launch condition fails and I get a pop up message. That's great, however I was finding that I had some prereqs that were popping up before that point and would need to be installed before realizing that I can't even install the program on the OS. So, to fix this problem I went through each prereq and set the OSs that the prereq would run under to the same as the launch conditions. This worked for every prereq except one. I can't seem to figure out why this one prereq is still showing up on XP. Listed below is the prereq in question and it's conditions tab contents.

Microsoft .NET Framework 4.0 Full (Web Download).prq
Registry has certain value - HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
User is running a particular OS - Windows Vista/Windows Server2008 (Any) (Service Packs=2 - )
User is running a particular OS - Windows 7/Windows Server 2008 R2 (Any) (Service Packs=1 - )
User is running a particular OS - Windows 8/Windows Server 2012 (Any)
Labels (1)
0 Kudos
(1) Reply
Level 3

I'm not sure why, but for some reason InstallShield was pulling a prerequisite with different conditions during the build. I've checked Tools -> Options-> Prereq tab and it had the correct path there. When I fixed the prereq in another location everything worked fine. So I guess the issue is resolved now.
0 Kudos