Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

PowerShell Custom Actions not running in New Style Interface Type


I added PowerShell Custom Action in my installscript msi project. When i used Traditional Style as InstallScript User Interface Type it works well.  But when i changed it to New Style it not runs during my installation.



Labels (1)
0 Kudos
(2) Replies
Flexera Alumni

Hi @Vladimir12 ,


What is the issue/error description you are facing with? Can you attach screenshot of that here?



0 Kudos

This is the way i do.

1.I made project with tradition style Interface Type(pic1)pic1.jpg

2. I addet powershell that installs IIS custom action(pic2)


and wana it runns after app search.

3. I install distr on test eviroment. and at the moment with "prepare to install" it runs my script (pic3)

pic3_prepare to install.jpg

. I added log screen (pic4)

pic4_log_running powershell.jpg

 and the whole log (_log_running powershell.log)

4. Then the need arose, to use New Style Interface Type and i changed it in my project and run build (pic5)


5. Then i run distr on the same test eviroment rolledback to same state.

6. Now "prepare to install" igoes really quicker and on Installation i have a warning "Installation requires an IIS server to configure the IIS virtual roots. Make sure IIS is installed." (pic6).


That means, my script didnt worked, and dist cant figuring IIS. If i end the installation. There is no actions in Log after appsearch, like in previous installation.(nopowershell.log) (pic7)




0 Kudos