cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sureshkottakki
Level 6

Passing Custom Propery and temp file path to log in command line paramters.

Hi,

We are using Suite installers to package the individual installers and we are passing command line parameters to suppress language pop-up, our own property and temp file path to create the log files.

The below command line is not working. I was using backslash to escape the double quotes. The log file is not getting created.

/L[ISSelectedLanguage] /v"/l*v \"%TEMP%\NMS.Platform.Installer.log\"" /v"MyProperty=true"

If we hardcode the path for log files it is working fine.

/L[ISSelectedLanguage] /v"/l*v C:\test.log" /v"MyProperty=true"
Labels (1)
0 Kudos
2 Replies
MichaelU
Level 12 Flexeran
Level 12 Flexeran

Instead of %TEMP%, use [TempFolder], or possibly [%TEMP] in your package command line.

That said, it looks like you're using a Suite EXE package to install a .msi file; I'm obligated to point out that we prefer using the Suite's Windows Installer package to install .msi files, at which point the Enable Logging Support settings can control this more directly.
0 Kudos
sureshkottakki
Level 6

Thanks a lot Michael, it is working grt
0 Kudos